Windows 8 laptop DHCP error 0x79

Hello all:

I am having an extremely frustrating issue fixing a friends laptop and decided to see if any of you could help.

The Backround:
The laptop I am working on is an Asus F55C-TH31, a few days ago my friend said the wireless stopped working.
After working on it for a bit he decided to reinstall windows 8 but it didn't help at all so he asked me to take a look at it for him.

The Problem:
First thing I did was download the latest wireless adapter driver and install it with a USB but it didn't help.
Next I tried plugging it into ethernet so I could download 8.1 and updates. However the ethernet only worked for a few minutes before it also stopped working.
So I launched Event viewer and found two errors relating to the internet connection.
Event ID 1001
and Error 0x79
both of them relating to DHCP issues.
I tried a few fixes from google but without any luck.
the IPV4 connects but when I go into network status it says the IPV6 has no connection.

I do not have a lot of experience when it comes to internet connection issues so any help would be great.



There are a few things we can try and see if it helps. First of all, I think the reason the re-install of Windows 8 failed is because Microsoft 'syncs' your settings. Once he logged back in with his Hotmail or Microsoft account, all the settings from the previous installation re-synced back the laptop, even the Network settings / DHCP issue.

I am curious, how is the IP from the router obtained? In your IPv4 property settings is it set to obtain IP automatically or manually?

Another question for you. Can you access the router gateway at all? (ie Can you ping your self even? command: ping I am wondering if so, it may be a proxy issue. Get back to us on that.

Have you by chance tried it on a completely different network? Maybe your family Wifi or I don't know Starbucks? That way we can rule out your friends router / network. Let us know see what we can do. We will get it figured out!

control panel > network and security > network and sharing center > change adapter settings > properties
it is in here that you need to make sure ipv4 is checked, try turing off ipv6 and see if that helps. Also make sure theres nothing strange there that doesn't need to be.

Then go to cmd and type in the following comands.

ipconfig /release
ipconfig /renew

That will release any old ip lease on the machine. Then do a ping test to your local gateway and then try pinging a website. Post results for further trouble shooting.