Windows 8.1 weird bug with HDD driver

English isn't my native language so, if my english is bad please don't complain.

I have WD green 2TB harddrive(my os is on a ssd), connected to a rampage 4 extreme motherboard. Whether I use the "Intel(R) C600/X79 series chipset 6-Port SATA AHCI Controller - 1D02" or the "Standard SATA AHCI Controller" i got this problem: when I shutdown/restart my pc the next time I boot my pc, my HDD isn't there, when I look in device managern the problem is this: "This device cannot start. (Code 10)", if I shutdown my pc by cutting the power or pressing the on/off button for long enough I don't have the error when I boot my pc.

So if I shutdown the pc using the shutdown button in windows, I can't use 1 of my HDD's.

The specs of my pc are:

CPU: I7 3820K

MOBO: Rampage 4 Extreme

GPU: Radeon HD 7770 + Radeon HD 7950

Storage: Samsung 830 256 GB (OS) + WD green 2TB(the drive with the issue) + FTP drive(I use "netdrive" as program) + optical drive

RAM: 3 x 4 GB G.skill ripjaws Z 1600 Mhz

PSU: Corsair ZX 850 Watt

Cooling: Corsair H100, and a lot of fans

My pc is very stable and not overclocked, I also have the newest bios version. I hope someone knows what caused this issue. Tnx for reading.


I would try this seeing as how everything else looks good so far.


1. uninstall the hard drive through device manager and RESTART the computer to let it find it itself, don't let it re install in the same running instance of windows.

If that doesn't work

2. Re install your chip set drivers for your motherboard and any secondary sata controller drivers.


Let me know if either of these solve your issue.

I have the same error code for a Wifi card and it was a BIOS version problem. I downgraded to a previous version of my BIOS and it was fine again. Later I upgraded when they released a newer version and the problem wasn't present anymore.

Tnx, but I've already tried both and it didn't work.

I also had it with the older version of my bios. And it only occurs when I shutdown the pc via windows. If I force it to shutdown via the power button it doesn't occur.

how long have you had that hard drive? can you replicate the issue in another pc? 

I guess I had the HDD for around 2 years. The problem occured when I installed windows 8.1 pro. And it only occurs when I shutdown my pc using the windows shutdown button. So I guess it is a software issue and not a hardware issue.