Return to Level1Techs.com

Windows 7 Installer USB3.0 UEFI

#1

Trying to dual boot Win7 on my X399 system. The install does not recognize any USB at all. The only USB2.0 is on the front panel and no luck. The UEFI does not have the old legacy settings, only option is to enable or disable the xhci controller.

Anyway, apparently there is a way to patch the installer with new drivers, just checking if anyone has done so and if they had any success.

0 Likes

#2

Asrock was nice enough to build a utility to patch the install media.

Of course it runs on windows… so you need to install windows to patch your windows installer.

0 Likes

#3

Intel also has a utility. Bottom line, use the DISM utility built into Windows to inject the drivers into the install media. I did this awhile back and keep it as my default Win 7 install media for newer systems.

0 Likes

#4

Thanks for the input. The installer worked but on first boot the USB controller didnt work. So back to Ubuntu, made a raw access vmdk and now im going to try ton install them from the VM and see if it boots…

Pain in the ass.

Screenshot from 2017-12-04 22-58-33

0 Likes

#5

It worked amazingly with a bit of fuss. I could install the drivers within the VM using command line with pnputil and it booted normally.

Win7 lives again, the last windows I’ll install. All in the name of some stupid fucking games I don’t have time for. Sorry Devember.

1 Like

#6

I’m jealous that yours worked. I made an installer with the DISM GUI … even got Windows 7 installed – and once I had direct access to the OS via TeamViewer – I STILL can’t get a damned USB driver to work for the Gigabyte version of H370M.

I posted a thread - but thought maybe you’d have some insight? Did you use a ‘special’ USB 3.0 Extensible driver ? Heh. Or other voodoo ? Wizardry ? ? :’(

0 Likes

#7

Try Windows 8.1 with Classic Shell. Should work for you. Ryzen Gen 1 and beyond for some reason has issues with USB devices on Windows 7

0 Likes

#10

Uhhhhh I don’t know how, they usually give me smashy smash tasks
Uhhhhh throws dart on board @novasty can you help with this

0 Likes

#11

I need a decoder ring. :slight_smile:

Is Win 8.1 nearly identical to Win 7 … ?

Networking
Firewall
AV + Malware (I don’t need help from windows)
updates / rebooting without my consent … ?

0 Likes

#12

Windows 8.1 has the app store and the ‘metro’ style start menu. Classic shell/open shell will take care of the start menu, and you can easily disable the app store in Windows 8.1 via GPO (unlike 10). Other than that, basically the same as Windows 7 (some backend stuff better supported like USB drivers/UEFI devices)

0 Likes

#13

AH!! That’s RIGHT! I hated that metro crap.

Anyway, I have the USB 3.0 / 3.1 drivers working and need only to finish getting the IG drivers working. Thanks for the suggestions and help. I’ll mirror some info here when I have it consolidated.

0 Likes