Windows 7 black screen with mouse before login

Hi everybody.
I was hoping there would be smarter people here than I am.

I have a Windows 7 desktop that boots into black screen with mouse, no login screen. You can move the mouse but nothing else. Ctrl-Alt-Del, Ctrl+Shift+Esc, Windows+R, Esc, Alt+Tab and Win+Tab does nothing.
Similar to this case: Can't boot windows 7:(

I have a password, one user account.

I know that this is Windows corruption because I had a faulty power supply that shut down the computer multiple times in a row.

I know that my SSD is fine as well as rest of the parts. This is all because of the sudden shutdowns.

Booting in to Safe Mode results in same black screen with mouse.
Booting in to Safe Mode with low res video results in black screen with huge mouse that can’t be moved.
Booting in to Safe Mode with Command line gives you black screen.

Bootting from USB Win7 installation media and running Fix computer gives nothing.
Runing SFC /scannow /offwindir /offbootdir finds some errors, fixes some and cannot fix all. Now, if someone knows how to read CBS log that is generated while booted from USB installation media, that would be really helpful.

Returning to previous save point did not fix the problem.

I have installed Windows 10 to another SSD and Windows 7 to third SSD, just to see that everything works.
Since I have the second Windows 7 installation that is working, I can transplant files to the broken installation, but I do not know what the files are.

Running SFC from the second win7 installation says that it can not fix all the errors.
Runing DISM and then SFC gives same results.
Trying to read CBS log with findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >sfcdetails.txt gives you an empty file.

I have a clone of the broken installation so I am willing to try anything and everything.

I have not yet tried to make another user account or tried to activate the Admin account.

I have not yet tried to see if user account has a backup registery, because this seems to me to be login service that is broken.

So, any help?
I am runing out of ideas and would really love to fix this installation instead of just reinstalling.
All the forums and threads about this problem have ended up in reinstall, but commoon, we are better than that. Or at least I hope one of you are. :stuck_out_tongue:

I had a similar issue recently and followed a few guides online and none of them solved it so I was left with nothing but reformatting and reinstalling everything also the customer needed the pc for work (well who doesn’t) in a timely manner (as usual business and no backups whatsoever).
Since you have already installed again windows, may I ask why are you trying to recover this one installation in particular?

I have seen this before. Or something similar

It was windows “added” a 2nd screen and was displaying everything on the fake screen that didn’t really exist, leaving the real screen solid black.

Once you boot and see the black screen, can you type your PW and hit enter to see if your desktop loads?

Hi Luca. Because I want to.
While it is true that I would have installed all the software, recovered the old files and could have even transfered firefox profile already with the amount of time I have put in to this, I simply just want to fix the issue to learn more and to get the old gal back. :stuck_out_tongue:

If it weren’t my own, I would have given up long time ago. You can’t really charge customer for this kind of learning operation. :smiley:

Hi Cosaga.
Now this! Why didn’t I think of this. I too have seen this before but somehow it didn’t even cross my mind. Thanks, I’ll test it tommorrow and report back.

If you still have your Windows7 disc you could give it a shot on repair. If you can get it to SAFE MODE I’d recommend doing the disc cleanup and removing all the old Windows Update files and old system files. Had a similar problem with the black screen and only mouse thing. This approach worked for me. I suspect it was due to PC inadvertently being shut down in the middle of an update. No reformatting was needed and I didn’t even need to use system restore. Note You need a Windows 7 installation disk. USB will not work.


I don’t understand, why would I need disc? As far as I know, the only difference would be USB drivers, but even that is not a thing since I am rocking first gen Core i hardware. Xeon W3680 and P6X58D Premium to be exact.
Not even that since I can easily add all the drivers to the install.wim and boot.wim with dism.

If you have a good reason, I can certainly burn a Windows 7 installation disc, I just don’t see any reason?
Maybe you have a newer system that has only USB3 ports and you haven’t added the drivers?

No go on the safe mode, as I explained in the original post. If I could get into safe mode, I would have easy time.

I can remove old windows system and update files from command line or with any of my other installations and pending changes with dism /revertpendingactions but I know that the reason isn’t updates.
Maybe I give it a go tommorrow anyways.

I have already tried replacing all the files in winsxs folder with files from the new win7 installation and then runing sfc. This should fix all update related problems.

So thanks but you were no help this time.

I’m only sharing what I did when I had the same problem and USB install would not correct the problem. I used an old Dell installation disc. It was a shot in the dark but I had nothing to lose. Once i got into the O/S in safe mode I cleaned up system files and rebooted to safe mode with networking. Windows did some more clean up and after that I could boot to full o/s and update. Did you also try checking your bios for the boot order? It sounds to me like you can get to sign in. I couldn’t even do that. All I had was black screen and cursor after the Win 7 logo screen did it’s thing. (In other words I tricked it into fixing itself.)

Thanks for trying @CHESSTUR, but if you had read the title, it says “…before login”. Login or sign in if you will, does not work.

So, did you even read my post…?

It is not a BIOS problem since I have already reinstalled Windows 7 to another disk. And I have reset BIOS and tinkered with the settings, since I two of my SATA ports are on different chip that defaults to IDE instead of ACHI passthrough.

Thanks but please read my post if you want to contribute.

Actually I did read your post but I thought perhaps circumstances had changed. After all, you’re running programs on the o/s you can’t access, yes? I’m just going over the things I tried when I had the same (or similar problem) I can’t explain why my methods work. I am not an IT. Many times I’ve tricked the system into fixing itself by attempting to do things that were not specifically used for the remedy I sought. Perhaps that is why these are called work “arounds”. If I recall what I read you can afford to lose the whole thing anyway. I won’t waste any more of your time. Have fun :slight_smile:

ive had this happen. solution was to wait for 10 min. or so, it eventally hits login

He might have gimped it up so badly by now it’ll never get there. :rofl:

I appreciate that you tried to help, so thank you.

I haven’t been able to get to my computer yet, so no, situation has not changed.
Yes, I can recover everything, thats what I do in my daily work. This is more out of curiosity than necessity.
And as I said, I am willing to try things, but since I have already tried what you are suggesting…

Hi @tkoham. I let it sit for 3+ hours before I did any repair attemps.
Windows 10 has had high disk usage that has prevented login, seen it many many times in customers computers. No dice in my case.

Good advice anyways.

…aand that’s why I took clone of the original before trying any repairs. :wink:

This really isn’t my first rodeo.

@anon79053375 @Eden @mihawk90 I think you guys might be intrigued by this.

1 Like

You try restoring registry hive files?

Intrigued? Yes, but not much of an idea to be honest. I had a lot of weird issues over the years, but most stuff just fixed itself.

Anyway, maybe I overread in the responses, but did the idea of a ghost-monitor go anywhere?
Can you try logging in blind? I mean there are not a lot of input fields, so should br easy. Or does it not respond to keyboard at all?

1 Like

Nope. Did not work. Not in normal, safe mode nor in safe mode with command line.
I did also test Win+Sifth+arrows to left and right, which should bring the cmd window to second screen. Nothing.
I also tested the borders with mouse, no second screen.
I could test with another gpu and vga since currently I have 1070 and DisplayPort, but I doubt it will help.

Hi and thank you @anon5644329 for bringing more people into this.

Hi. I don’t know, there is no indication one way or the other. Since it does not respond to power button, I think it is not responding at all. I haven’t tried caps lock though…
-edit- Tested caps lock as well, it does respond, so it’s not input problem.

Hi to you aswell. No I have not. Registery is something I have litle experience with so all the help is appreciated.
Only thing that I know how to do is change the backup userprofile active.

I also tested replacing winlogon.exe with the working W7 install ones. No change.

So, I contacted Microsoft “technical” support. He was very useful. Never even heard of SFC. Promised to ask around for the CBS.log in WinPE. He send an email saying that usually CBS.log is in C:\Windows\Logs\CBS. So I sent him a email back that thanks, but I was asking about WinPE.
Then I got an email from escalation team, apparently it costs 41€ to get anything useful out of Microsoft. :roll_eyes:

Anyways, I found that you need to set environment variable to change the location where CBS is saved.

So since I have already replaced some files, broken and rebuild whole boot partition, poked around and replaced the whole registry, I think I take another clone of the original and test this with a fresh copy. :smile:

If I figure this out, I will post step by step in hopes that others don’t have to try everything.