Windows 7 and 10 Dual Boot USB Recognition Issue

So, the keyboard, and mouse (USB connection), will flat out not function sometimes when booted into Windows 7 and I don’t know why this is the case. They’re both plugged into USB 2.0 ports on the rear I/O of the motherboard. This seems to only occur when switching between Windows 10 and Windows 7. The only solution that I’ve come to for this problem is to hard reset the system, and then boot in again. Is this a common issue when switching?

Upon further testing, it seems to be USB related. As a PS/2 keyboard was used when the issue occurred and functionality was still there. However, the mouse is /was still plagued by this issue.

Any ideas? BIOS setting? Drivers related?.. I don’t know on this one.

edit- I also noticed that during Windows 7 startup/boot, if the mouse is being moved while booting Windows 7, the system will restart on its own. Upon rebooting to Windows 7 after this issue occurs, Windows 7 will give the option to launch startup repair or boot normally.

edit2- from this, the issue seems to be software related. I don’t see how it is/would be hardware related.

(Thank you for PS/2 ports)

Have you got fastboot enabled in the UEFI?
At least when switching between linux and windows, this has led to some hardware initialization problems for me, and it was recommend to turn it off.

If you wanna check your drivers, uninstall the USB hubs and ports from the device manager, and I would do the chipset as well, then reboot and reinstall.

I do. I’ll try turning it off and see what happens.

Disabling it gave the same results. Doesn’t look like it’s responsible.

Well, upon looking for the latest drivers for my motherboard, I found a bunch I didn’t download. Thank you for that.

They were hiding in subsets.

What the fuck?

Installing the USB 3.0 driver seems to have fixed it.

How does that even make any fucking sense? The keyboard and mouse are plugged into USB 2.0, not 3.0.


I am not surprised that installing the 3.0 USD driver fixed your issues. My guess why your issue was fixed by installing the 3.0 USB is your 2.0 Drivers where corrupted and installing the 3.0 USD driver fixed them. I have come across a few situations like this.

The USB 2.0 drivers are/were not corrupt. This was done several times with fresh installs and the same results occurred.

Glad to hear you found a solution for your problem, even if not directed to by my suggestion.

PS.: Mark the thread as [SOLVED] when no more problems occur.

It wasn’t an available option from the forums at the time.