Windows 10 LSI 9211-8i troubles

@wendell I bought a new LSI card and it still isn’t working with my PC(previously posted about my problems here: LSI SAS 9207-8i and windows 10).

I can boot into its BIOs and yet again it says it can’t detect any drives. They are all 400 GB Seagate Barracuda (model ST3400832AS).
Is there something I need to do to get them to show up in the LSI controller? Is there some other setting or configuration I need to do?

PS C:\Users\John\Downloads\9211-8i\SAS2IRCU_P20\SAS2IRCU_P20\sas2ircu_win_x64_rel> .\sas2ircu.exe 0 DISPLAY
LSI Corporation SAS2 IR Configuration Utility.
Version (2014.09.18)
Copyright © 2008-2014 LSI Corporation. All rights reserved.

Read configuration has been initiated for controller 0

Controller information

Controller type : SAS2008
BIOS version :
Firmware version :
Channel description : 1 Serial Attached SCSI
Initiator ID : 255
Maximum physical devices : 255
Concurrent commands supported : 1720
Slot : 57
Segment : 0
Bus : 11
Device : 0
Function : 0
RAID Support : Yes

IR Volume information

Physical device information

Enclosure information

Enclosure# : 1
Logical ID : 500605b0:01680280
Numslots : 8
StartSlot : 0

SAS2IRCU: Command DISPLAY Completed Successfully.
SAS2IRCU: Utility Completed Successfully.

Take a lot of pics for me
Show me cables and plugs and stuff. Your cabling is staring to be suspect

1 Like

@Blacksmithforlife If you purchased the cabling from an online retailer, a link to that may help. What I believe Mr. Wendell is eluding to may be that you are using a reverse breakout cable instead of a forward breakout cable.

I’ll try and make this short, But essentially, the 2 different cables look pretty much the same but differ in how they are used to carry data. In your case, you would need a forward breakout cable. Foward Breakout cables are used to go from a HBA/RAID card and connect one of the ports on your LSI 9211-8i to 4 x sata drives. This is your configuration.

There is a less likely scenario that would use a reverse breakout cable and that would be to connect an sff-8087 port from a drive backplane to 4 separate SATA ports on your motherboard. In this scenario, you would have a chassis with a SAS backplane that you drives all slide into and then you use one of these reverse cables to connect the backplane directly to the motherboard without the use of an HBA/RAID card.
So although these 2 different cables may look physically the same, they cannot be used interchangeably.

Side Note: regardless of the type of cable you may or may not have, double check that everything is plugged in right. I’ll tell you right now that I have plugged in sff-8087 connectors upside down before and 4 of my drives on my 4 x 8087 port backplane wouldn’t show up. Also just double check all of your other cabling as well. Including power supply side SATA power. If your drives aren’t getting power but everything else is right, they still won’t show up.

Let us know if any of this helps. And don’t forget to post those pictures and links if you have them. Cheers

EDIT: So I just went down the rabbit hole of your last thread with the 9207-8i that you switched for this 9211-8i. I’m going to leave the rest of my response up just in case it has something in there that helps you. But I did notice one thing from the previous thread that I don’t know if you answered.

I believe he was referencing the old card (9207) but it is still a good troubleshooting step, have you tried using both of the ports on the 9211-8i?

I have also purchased numerous 9211-8i’s from that same ebay seller that you linked to and have yet to have an issue with any of them. I know you probably don’t want to test any more cables, but I’ve had fantastic results with cable matters SAS breakout cables here They’re relatively cheap so if you want to take a crack at different cabling again it wouldn’t break the bank.

Still let us know how everything goes.

1 Like

After the last card didn’t work I returned the cables and bought new ones. Here is what I ordered

Comparing it to your suggestion it looks like I ordered the wrong cables. So I just ordered the ones you suggested (thank you).

Perhaps this is another dumb question, but once it is working, those drives should just show up in windows correct? Or do I have to do something else?

Photos as requested

The cables you ordered appear to be forard breakout so they should be ok but it doesn’t hurt to try different ones.

So unrelated, Is your front panel USB3.0 ports working? That cable looks like it might be a little unplugged.

Back to the issue at hand, I did want to try one other thing. Can you un-cable manage the breakout cables (read - take it out of the velcro straps and keep them as far away from other cables and as unbent as possible)and try and isolate them from any other cable interferrence. It’s kind of a long shot but those tiny blue sata breakout cables are very tiny and thus not well shielded from electrical interference. I’d be curious to see if that could be the culprit.

Not a dumb question. I’ll tell you up front that I don’t know the exact answer to that question. All of my experience with HBAs has been limited to server type installations normally running FreeNAS or UnRaid. Those operating systems support these cards very well. Windows 10 is were it gets a little murky. These cards are shown on the Broadcom page to have been fully supported in Windows 7 32/64 bit . There is a driver available for Windows 8.1 as well but no real mention of Windows 10 probably due to age. That being said, since the card is flashed to IT mode acting as an HBA instead of a raid card, they may just be served up to your computer transparently as just sata connected drives. But once again, I am not 100% sure. Before you worry too much about it… the main goal at this time is to get the card to see the drives. After that, we’ll see how the computer/OS handles the drives.

Where’s the listing you bought this card from btw? Are you sure it’s flashed for IT mode?

1 Like

I bought the card this time from amazon (used because the box was damaged)

Looking in the card bios it had options for RAID so I am thinking I will have to flash it. But I believe the drives should still show up first regardless of what mode it is in, no?

I will try moving the cables later today and report back if that solves the issue. I did double check the USB 3.0 header and it was a little bent but I believe it was in correctly. I don’t own any USB 3.0 devices so I never use those ports.

On second thought, You may need to flash that card for P20 IT mode since there was no specific indication on the Amazon listing that states that it was preflashed.

Did you have to return the 9211-8i that you got from ebay after receiving your refund?I know that was a question at the end of your other thread.

They won’t show up in windows. I haven’t played around with a non flashed card to see how they would appear in its stock bios.

I can maybe do you a favor though. I have a known good card I flashed myself. If we can’t figure this out I can part with it for what you paid on the Amazon one.

It’s an IBM M1015.

Its currently in use in my backup server. I can order another one to flash.

That is super generous of you! But I first want to try to get this one to work. I feel like a lot of the problems are just that I have never dealt with a sas card before so I am kinda walking around blind. I did download almost everything I could get off LSI’s website (broadcom now?) so as long as you can point me to some good documentation I am willing to learn and flash the 9211-8i myself.

So if the drives don’t show up in windows, how do you access them in the local machine? I suppose I could setup another machine but why waste the electricity if I can do it all in the same local machine? Plus then I don’t have to deal with local network (limited at 1GB/s).

The instructions for getting a refund new said it had to be returned, so I still have that old card. Wendell had offered at one point for me to send it to him so he could diagnose. I would still be up for that if he is interested (how he has to time to do all he does, I don’t understand) I would just need his address for shipping.

A quick look at the card BIOS should tell you what mode your current card is flashed to. Before you try any flashing or any other steps.

Yeah, obviously I want to help you get this working first before I part with my card. I’m not sure whats available officially for flashing these cards. I used a combination of guides from serve the home and freenas forums. It was not fun or easy. Luckily I left myself some notes.

This is for a different card but I think the process is similar. They are the same controller by LSI. You can look up different guides for yourself and come up with a plan of attack. This is just what worked for me.

You’d have to make a RAID before it would show anything in windows. You should be able to see the drives in the BIOS of the card though, I just dont know what that looks like to tell you how. I would first verify what @Whizdumb mentioned.

@Adubs @Whizdumb
First, thank you both so much for all the help you have provided so far. The cables that @Whizdumb suggested came today. I tested the spinning drives away from the other power cords using the new SAS cable and still nothing showed up.

Out of desperation I tried hooking up an extra SATA SSD I had lying around. And this time it showed up! I tried using the SAS cables I originally bought and it showed up again. So at this point I think I can safely rule out that it is the card or the cables.

So why in the world is the 9211 having trouble with the drives?! I took a photo of the hard drive
Google Photos
it is just a seagate barracida 400GB. I had gotten them from an old server that a friend was getting rid of. If I directly attach them via SATA to the motherboard they show up just fine. There are 4 pins on the end, do I need to use a jumper or something to change so they are picked up by the 9211?

phone shots of bios showing version and it picking up the SSD:

I have never encountered drive incompatibility with an HBA. That’s certainly an interesting problem. Sounds like it might be time to get some newer, bigger drives. I would recommend that anyway seeing as how you are on borrowed time with drives that old.


Yeah, but you can’t beat the price of FREE. Is there no way to get these to work? What I don’t get is, why do they work when using SATA directly to the motherboard but not attached to the card?

Believe me… I have the same question. After a quick google search, i wasn’t able to find this as a common issue or find a fix. Even if you had 8 of these 400gb drives, you could get all of that capacity with a single 4tb drive for under $100. Just return all of the excess cards, cables and everything you bought to troubleshoot and start building up a storage array by buying bigger newer drives one at a time.

Even if you had 8 of these 400gb drives, you could get all of that capacity with a single 4tb drive for under $100

Yeah I will probably end up doing that. But this weirdness is just bugging me. I am a programmer as my day job, and I can’t help but feel like there should be a simple fix for this. I hate to leave this unsolved.