Windows 10 hangs on install - ASRock Z370, i5-8400

Hey Guys.

i’ve got the new pc of a friend here and I’m trying to install windows 10. It always hangs on the windows logo (no spinning dots).

Things I already tried:

  1. Make a new installation media with media creation tool (USB and DVD)
  2. Tried the installation stick on other system in UEFI and Legacy mode. Works fine. Even installs windows.
  3. Tried an ubuntu install on the “bugged” machine in UEFI-mode. Works fine.
  4. Stole an HDD with installed windows 10 from a skylake machine and plugged it in the bugged kaby lake machine. Still hangs at the windows logo
  5. CMOS Reset
  6. UEFI Update
  7. Unplugged everything except installation media and dvi. Even internal connections.
  8. Tried at least 4 different usb-sticks and every port on the board.

So, I can find no flaw in the system or the installation media. It just doesn’t work together. The hardware was tested by the dealer, but I added a 550W PSU, since it was somehow not included (weird…).

Config:
i5-8400K
ASRock Z370 Pro4
16GB DDR4
Samsung 960 Evo M.2
2TB WD Blue

And there I thought I’ve seen everything, but this is new… Please help, I’m going crazy with this thing.

Try running Memtest86+

1 Like

My rig did the same thing. The ram was dead so test your ram in a different rig

1 Like

Hey I’ve also had my friend dump his computer on my desk with exactly the same issue. I’ve been tearing my hair out trying to install windows as many ways as I can to no avail. My friends rig is awefully similar to your friends too.
Config:
I5-8400
Gigabyte GA-H270-HD3
16GB DDR4
Samsung 850 Evo SSD
2TB WD Blue
And idk if it matters but Corsair CS750M

Absolutely any help would be appreciated