Windows 10 Fall Creator's Update: Strange connectivity issues... I'm stumped

Over the past few weeks I’ve been upgrading the points of sale at work; up until this morning, things have been working fine…

While I’m relatively certain that it’s just a bad update or something stupid that will get fixed soon (before the end of the month, I hope)… This just doesn’t make sense, the connectivity indicators say no internet access, but pings work fine and web pages load.

Screenshot (2)

They are statically assigned IP addresses, and not every machine is affected. I have tried running netsh int ip reset but all that did was clear out the IP info that was assigned… It seems to resolve itself when I reseat the ethernet, but happens again after a reboot.

I would just let it go since connectivity is actually working, but the service that manages credit processing won’t start with Windows reporting “no internet”.

In the meantime I’m going to start working out a script to work around this problem, I’ll post it here if I get it working, and/or find a better fix. Might come in handy again in the future since there’s already been reports of similar issues on either 1507 or 1607 (can’t remember which).

If anyone has any ideas of things to try besides reinstalling (that’s usually my go-to, but I don’t have enough time to do that at this point).

I had similar issue. Also several others that made me just roll back. Too many to troubleshoot with lack of time to do so.

My Hyper-V NIC settings got screwed up during the update.

There’s should be an option in Win 10 settings to reset the IP settings or NIC settings I can’t remember but I did I that it started working again. Maybe worth a try.

I remember in for previous version of Windows the DNS settings would get corrupted and you could run an IP Stack reset command so it may be similar to that.

I’m pretty sure that netsh int ip reset is for resetting the IP settings, which I did try. Didn’t occur that the actual NIC settings were separate herp-derp

I ended up giving netsh winsock reset which according to what I’ve read is supposed to reset the NIC settings… But still no change from that. Then I tried Windows Troubleshooter, ran this on the NIC itself.




That seemed to work at first, but then I checked the IP settings and had to reassign the static… So I’m back to square one…