Return to Level1Techs.com

Win 10 KVM guest refuses to upgrade to 1803 or 1809 0xc1900101

helpdesk
kvm
virtualization

#1

I have a win10 KVM currently on build 1709. The KVM is nothing very fancy, typical setup with only a SATA controller passed through for win10 on a 4gb sata ssd. Host is Ubuntu 18.04 with 4.19.15 kernel

Windows tries to upgrade itself, and it will download the update say it’s ready to reboot but then fails to update. No warning messages or anything. I go look into windows update and it simply says it failed with 0xc1900101. Then it tries again. Rinse and repeat.

There is only one program installed in win10. Nothing else, not even AV. I have even tried to upgrade with a 1809 iso. Boot to the iso and the spinny circle on the bottom works for a few seconds, then reboots itself back to the “Press any key to boot to cd/dvd rom”

Any ideas?


#2

0xc1900101 is a quite a generic error and usually points towards a driver (or BIOS) issue.

Do you not get an extend code returned after the general code? If you do, it’d be worth cross referencing with this page https://docs.microsoft.com/en-us/windows/deployment/upgrade/resolution-procedures

However, as you say it won’t boot to an ISO of the image… the problem maybe within KVM (or the ISO). Out of curiosity have you enabled Nesting within KVM?


#3

I figured it out finally. Disable cpu passthrough in Virt Manager and it upgrades fine now.