Win 10 BSOD - Kernel Security Check Failure - Troubleshooting


I would appreciate assistance with the first ever BSOD I’ve encountered on my current desktop. The BSOD error is the terrible Kernel Security Check Failure.

Here’s a link to the crashdump:

I have made no changes to my drivers since NVIDIA’s last WHQL driver in mid December, 2016. In the past two weeks, I’ve reseated my heatsink to apply new TIM, and took out some fan splitters that were unnecessary and changed my fan control for my 3 pin fans that were previously running at full speed to advanced fan control in my BIOS, in order to lower the RPM, as well as some dust removal – anti ESD measures were taken. The BSOD has only occurred since installing a free trial of Adobe CC/Premiere Pro a couple of days ago. Reproduction currently is to have Adobe CC/Premiere open (not rendering or anything intensive) and within an hour a BSOD occurs giving Kernel Security Check Failure.

First, some information on my system, built around December 2013:

Windows 10 Home 64-bit, 1607/Anniversary Update, all updates installed as of this posting.
Motherboard: ASUS Maximus 6 Hero (Newest UEFI installed)
CPU: Intel Core i5 4670k (Haswell) at default frequency
GPU: ASUS Strix (08G) NVIDIA GTX 1070 with the revised Micron VBIOS
RAM: G.Skill DDR3 1866
Storage: Samsung 840 EVO 256 GB (Latest firmware installed), WD Black FAEX 2 TB
PSU: Corsair AX760i

Anti-virus: Avast 12.3.2280 (latest) with newest definitions

What I’ve tried:

A full memtest86 run.
I’ve run sfc.
I’ve run chkdsk /f and /r.
A boot-time virus scan.
Windows built in diagnostic software for devices/hardware and BSODs.
Device Manager does not display any warnings.

All tests have been clean.

CPU-Z, Speedfan, GPU-Z show no abnormal temperatures, voltages or issues of that nature.

While I don’t own a PSU tester or a multimeter… this BSOD prompted me to order both just in case. If power could be the issue I won’t be able to test until later this week.

Please let me know if I can provide any more information.


From your memory dump file:

Unable to load image \SystemRoot\System32\cdd.dll, Win32 error 0n2
*** WARNING: Unable to verify timestamp for cdd.dll
*** ERROR: Module load completed but symbols could not be loaded for cdd.dll
Probably caused by : cdd.dll ( cdd+1316 ) 
PROCESS_NAME:  audiodg.exe

So it's your audio driver.

  1. Try updating it.
  2. Try selecting a different driver. Device manager -> Sounds -> right-click audio driver -> update driver -> browse -> let me pick -> pick a different one -> next -> ok -> reboot computer
  3. Try uninstalling it and using an external sound card.
  4. Try removing the external sound card and using the internal audio.

Random info:

1 Like

Thanks very much for taking the time to reply. I disabled the onboard HD Audio and NVIDIA audio drivers (I had no idea NVIDIA intalled audio drivers...even though I do a custom install on each GPU driver update) as I don't use either interface, and I uninstalled the software/driver for my Fiio e10k DAC/Amp and will just try the default Windows driver for it which seems to work fine anyway. I'll report back if that fixed it.

I'd really like to know, though - if it is my audio driver - what could have prompted the BSOD to start occurring now?

That Fiio e10k DAC/Amp is probably it. It scares meh o.o

Are you using HDMI but were not before? Maybe unplugged it recently?

An electric discharge could also cause it, so maybe an electrical storm or the power going out and coming back suddenly with the speakers/computer/amp connected to different circuits.

Hardware also does just fail after a while.

Windows 10 tends to update drivers in the background and ignore the whole "do not update drivers if they are working" concept. So maybe the "newer" driver software is just buggy.

The FiiO E10K is quite a popular portable-ish DAC/Amp - it runs via USB although I think the PC sees it as SPDIF.

It is driverless more or less, but being me, I still looked to see if there existed any manufacturer driver/software. Might have been a poor decision in this case. I've had it installed since November.

The software was uploaded to Dropbox by the company though instead of a mirror on their site, and there's no datestamp or changelog I don't think, so you're right... it's probably not the greatest with that in mind, ha.

My wife is the one using Adobe CC to try some editing on my desktop, so I'm sitting here waiting to see if the BSOD reoccurs.

Edit: It hasn't reoccurred. I'm calling it resolved. Thanks for your help, Peanut.

Actually kind of surprised win 10 didn't auto uninstall it in the background.