WiFi Issues with Ubuntu 16.04 dual boot on 2015 Dell XPS 13

I've had Ubuntu 16.04 LTS installed on my my new laptop for about 2 weeks. When I first booted into Ubuntu I had no issues at all, WiFi worked well and I was able to connect.

Now for some reason when I boot into Ubuntu I can't connect. There are no networks available and it seems to be stuck in a connecting state. Any ideas to help? and what other info can i provide to help?

Linux noob if you can't tell so if you could explain real slow like... - in Logan's southern voice

what WiFi adapter/card do you have ? and can you connect with a cable and try sudo apt-get update into the terminal

Ok i've updated. We'll see if any magic happened. As for the wifi card see below.

sudo lshw -c network

  *-network               
       description: Wireless interface
       product: BCM4350 802.11ac Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: [email protected]:3a:00.0
       logical name: wlp58s0
       version: 08
       serial: 30:52:cb:80:34:19
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=brcmfmac driverversion=7.35.180.119 firmware=01-e791c176 ip=192.168.1.144 latency=0 multicast=yes wireless=IEEE 802.11abgn
       resources: irq:283 memory:dc400000-dc407fff memory:dc000000-dc3fffff

Have you disabled wifi in network manager in you system tray?

My friend had a similar issue with his XPS 13. From what we worked out that adaptor isn't supported in the stable Ubuntu kernel yet(or wasn't).

Just out of interest could you run this WiFi trouble shooting script and post the results?

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && \
chmod +x wireless-info && \
./wireless-info

(cant remember for the life of me the proper way to post up commands on here)

Well it looks like the system update seems to have helped. I've had my wifi working across multiple login attempts. Thanks for the comments all.