Why is YouTube still restricted when on SOCKS Proxy? [SOLVED]

On a network that has YouTube's restricted mode enabled, I am running my computer through a SOCKS proxy via SSH, which is encapsulated in SSL via stunnel. When I view my IP on cmyip.com, it shows my server's IP address, so I know that the proxy is working. Additionally, websites that were once blocked are now unblocked, which is another sign that the proxy is working as it should.

Despite all this, the YouTube restricted mode filter is still in place. I cannot disable it, because when I try, it says "Restricted Mode is enabled by your network administrator." The video does not play, and says "This video is restricted. Try signing in with a Google Apps account."

I'm not so worried about making this work as I am interested in how the filter is still in place despite my being on a SOCKS proxy. I want to learn why this is happening so that I can get a better understanding of the networking concepts behind it.

Does anyone know what's up? Thanks.


This was solved by installing DNSCrypt, essentially encrypting my DNS packets so that they could not be tampered with by the network's filters. Turns out they were using this method to block YouTube videos, even while I was on a proxy: https://support.google.com/a/answer/6214622

youtube is blocked at the browser level. if you are on chrome type chrome://policy to see what policies are enforced.

Thank you so much for the reply!

When I visit chrome://policy, it says "No policies set". I am on my own Surface Pro 3, not owned by the administration, so they have not installed anything on my computer.

have you tried signing in with your personal account. might be blocking it with your account.

Yes, I am signed in as my own personal account. I've also tried in incognito mode. Thanks again :)

might not have web address encryption enabled. so even with your socks proxy they can where but can stop you.

They shouldn't be able to see what websites I'm connecting to. I opened wireshark and all of my connections are going to my server's IP address. The requests are not only being made through SSH, but they are encrypted with SSL (I'm using stunnel to do this.)

is there any way it is blocked at your server?

It's possible that it's internal DNS resolution. You might try to use a public resolver and see what happens.

I just tested the same proxy with the exact same setup and Surface at my house (which does not have restricted mode enabled on YouTube) and I can now see all the videos that were blocked. So I don't believe that my server is the problem. It must be something with the other network.

I tried using Google's DNS and nothing changed. I'm not certain that it saved the DNS settings correctly though, so I will try again tomorrow morning.

Yeah, try manually configuring a public dns server for your network connection. However it is still possible for them to intercept your dns requests and modify them, so you might want to have a look at dnscrypt.

Will do, thanks :) I have never heard of DNSCrypt, but I'm glad you mentioned it. I'm going to install that regardless of whether this works or not.

1 Like

That worked! I installed DNSCrypt and now I don't have any YouTube restrictions :) I also found out what they were doing to the DNS to make this possible: https://support.google.com/a/answer/6214622

Thanks so much for everyone's help, I really appreciate it. I had no idea that DNS could do this, so I'm glad to have learned something!

Also, this is my first time in this community and I'm blown away by the amount of support. Reddit kicked me to the curb when I asked this question on /r/networking.

Thanks again :)