Return to Level1Techs.com

Why is ubuntu installation so unreliable

helpdesk
ubuntu1810

#1

Right now, I’m having difficulties installing ubuntu on my laptop Clevo N850.

I’ve downloaded ubuntu-18.10-desktop-amd64, hash matches so the ISO is not corrupt.
I’m using rufus 3.3, selecting the iso, selecting GPT partition and it writes fine.
Disable Fast Boot, Intel Speedstep and TPM. Kept secure boot on.

Go through the installation fine, setup a secure boot password, disable encryption. Get right to the end of the installation with a message box saying
“Installation is complete. You need to restart the computer in order to use the new installation”
Click Restart Now and nothing happens. About 7 Minutes later I get this screen
https://imgur.com/a/vZDi6xT
Keep waiting and nothing happens, so I hold down the power button to do a hard shutdown, and boot back up again, It asks me for the secure boot password, I enter it and then we boot. I get to the login screen, type my password in, Then it freezes. Can’t do anything.
https://imgur.com/a/OreuLyg
I’ve been told that secure boot works fine with ubuntu, I shouldn’t have to disable it, Maybe I should try the LTS version of ubuntu? or should my installation media be using MBR? or should I try and use a different memory stick to install ubuntu on?

As far as I am aware im not doing anything wrong.

Any advice would be great thanks.


#2

AFAIK you have to enrol the secure boot keys via MOK which it should have prompted you to do on reboot. Can you please list your cpu and gpu?


#3

I believe that is what I have done, but I’m not sure if I did it correctly, I selected MOK and entered password, Do I need to select enrol key? and then what do I select, I cant select the EFI/boot/bootx64 it says its unsupported.

CPU is i5 8300H
SAMSUNG 970 EVO M.2
GTX 1050M


#4

Yeah if you do it wrong you are not allowing the OS to install GPU drivers - hence the black screen.

So when the blue screen pops up on boot saying enrol MOK key, you wont be able to see the key, but enrol the key and you will have to put in your password (the one you made during installation - prob your root password). You wont see anything happening when youre typing but from memory, its

Enrol key, type password, reboot. There are prompts. IF you get stuck ill try and record me running through it for you to follow.


#5

It’s Nouveau. You need to disable Nouveau then install the Nvidia drivers. Nouveau has been a nightmare on 18.04 and 18.10. Just don’t use it. Start Ubuntu with nomodeset nouveau.blacklist=yes as kernel arguments in /etc/default/grub.


#6

The first screenshot is talking about your Mount points. How did you partition your disk? Did you do it before the instalation so you have an active boot partition?


#7

I’m pretty sure that’s how I did it. But Ive also now tried to disable secure boot and reinstall, and still the same problem so I dont think its a secure boot problem.


#8

I didn’t do anything special with partitions, During ubuntu installation I just selected Erase Disk, I assumed ubuntu would then just handle the partitioning alright.


#9

if it is possible try and disable that horrendous atrocity they call secure boot.
And just boot legacy.
it makes sense if you’re a big company wanting to secure your data, but as a home desktop, it’s just stupid, unless you’re really affraid the FBI/CIA will wanna boot your OS.


#10

A few tips…

That laptop basically doesn’t exist, a quick search yields no relevant info regarding the specifications. I can only guess what hardware is in it.

Your pictures and experience are a good indicator that your installation was successful in the first place. Be sure to post clear images where the text can be read if you want to have better chances of resolving issues.

As @FurryJackman stated this appears to be a video issue which tends to effect nvidia hardware. I’ll help him elaborate… To change the boot options in grub you need to press shift after post but before the os boots. Add nomodeset to the line that starts with Linux. It will probably have “quiet” and “splash” in the same line.


#12

done what you’ve said but can only get get into the command line. what now?


#13

Type dmesg and see if there’s any indication of what broke.


#14


#15

I’d try installing the nvidia drivers, I think 390 is the latest but I’m not sure.

sudo apt install nvidia-390

Then type reboot, or reboot now


#16

Also be aware that some laptops have two GPUs and use the nvidia optimus which is a pain from what I remember.


#17

I have to do. I have two gpu’s. how do i do this?


#18

Easy way would be to disable the igpu from the uefi.

I have no idea if this will work but if you’re feeling adventurous…
https://wiki.ubuntu.com/Bumblebee


#19

It says right plain and simple there, Nouveau tried to load before the kernel panic.

Remember, to blacklist nouveau, do BOTH a update-grub and update-initramfs -u