Return to Level1Techs.com

Why does CUPS suck so much?

So CUPS. And an older Lexmark Pro205

I have a choice. Filter error or insecure permissions. Can go either way, but can’t print in Kubuntu 1804, Ubuntu 1804.

Windows 10 seems fine.

CUPS is great, you just have a printer with shit Linux support.

Praise be to HP and Brother.

7 Likes

Praise be to HP and Brother and Epson as well

6 Likes

Sadness. Such sadness.

Now I know why they donated this ‘awesome’ lexmark

2 Likes

Yeah, Lexmark is a big no in Linux.

CUPS works better for me than Windows. My printer is setup for DHCP. Whenever it happens to get a different IP, the Windows machines break and I have to run the Brother Network Printer Driver Repair Tool. However the CUPS driver does an SNMP probe so it always works. Plus the printer does an mDNS/DNS-SD advertisement of its status web UI so I can easily discover it on my Linux box as well.

But it’s Brother, not Lexmark. :wink:

1 Like

Your thread title sucks.

Printers just suck in general.

3 Likes

Why no one help OP? Is it really not at all possible to get his printer to work with cups?

Lexmark has some printing and scanning utilities that you can download on their website. Don’t know if you used them.

One solution that I had to use, was to use Docker and an older Linux+CUPS version to get mine to work.
Though I had to expriment quite a bit to finally get it working. With that permission are mostly irrelevant though, mostly.

I got it to work two ways:

(1) Regress CUPS and set backend LXHCP (name) and printfilter permissions to 775. It’s on a LAN, so i don’t really care about security on the printer. Then it wouldn’t throw the insecure permissions error.

(2) Use Ubuntu and Gnome 16.04.1 LTS. Just happens the classroom server was originally built on older hardware, so wouldn’t support the new kernel. Changing the printfilter permissions to 755 worked.

(XX) Direct USB to windows. Works instantly. May built a light printserver if I get mini-itx or micro-atx doner comp.

1 Like

Way to go bro! Good job on soldering on not giving up!

1 Like

I thought this was about athletic wear :slight_smile:

2 Likes

never had cups problems.
My guess is your printer is badly linux supported, and you’re lashing out on the closest target.
worst printer/scanner experience ever had was…
My current printer has a limit where if it runs out of toner(black/color doesn’t matter), then for some rediculesly reason my scanner doesn’t work #lovereasons, which is a printer firmware problem nothing todo with cups.
else cups has allways worked for me, regardless.
But if i were you id google that problem and see what the community has to say about your exact printer and cups, usually someone has a solution to your exact problem, and hardware.