Which graphics cards have the reset bug again?

Hi all,

I’ve been out of the passthrough game for a couple of years and I’m about to start a new project with some Ryzen hardware I have lying around from my recent upgrade and mining. Having a hard time tracking down which cards have the reset bug. Tried a couple of searches, but didn’t come up with a definitive list. Please fire back with what you know!

Much appreciated

@gnif probably has something for you. I wish I knew more but I’m just not a pass through kind of guy.

Afaik it’s mostly Amd Vega or older cards that aren’t UEFI compliant? So if you get anything in the last gen or so that isn’t Vega I think it’s safe but don’t quote me on that. The new AMD 5700 GPU’s have some driver support issues under Linux I believe but that shouldn’t be a problem for passthru. But you might want to verify someone has successfuly passed one to be on the safe side. I might sound like I’m being overly negative on AMD, but that’s the way it is. Also have to tinker with your VM a bit to get the Nvidia drivers to load inside a VM.

That said I’ve passed through a RX580 on my machine so I’m not minding Vega and playing wait and see on the new AMD hardware.

Ran into the reset bug on a Dell OEM Radeon RX 580 8GB. FWIW it was probably a re-flashed RX 480.

I wouldn’t be surprised if they got them cheap because of a hardware issue and the flashed a work-around. If it will save them money, they’ll do it. :stuck_out_tongue:

Ah, I see. So the UEFI code in the current Vega BIOS doesn’t cut it? I could’ve sworn that I saw the UEFI check mark in GPU-Z on my old mining rigs. Am I missing something?

Not familiar with the details I just saw it in passing I believe this is probably the thread Adubs meant when he mentioned gnif -

I have not heard of any reset issues with nvidia cards at all.

People have been having issues on and off with AMD cards since the r9 series, and possibly before, although there where not many people doing passthrough that far back. Sapphire cards with their different vbios sometimes have been better, and there have been workarounds, such as the Vega fix linked above.

1 Like

Personally I haven’t tried an nvidia gpu vfio but I’m not a fan these days between them trying to block driver loads in VMs and their proprietary SR-IOV-like software stack that is most likely slowing the adoption of actual SR-IOV graphics.

@gnif has a piece of software which fixes the reset bug I think. Could be wrong. I know he was posting on the AMD subreddit about the issue and was working to resolve it. Again, I dont do the thing so I dont know much.

As an aside, could we not turn this into a moral debate on AMD vs Nvidia pls. thanks.

Confirmed, a fix is coming but it will be in the form of a kernel patch and not a third party tool. I am sorry for the delay, I do this work as a hobby and actual paid work has had to take priority at the moment.


I do not thing UEFI support has anything to do with reset?

UEFI support on the card does make it so you can use OVMF, which is nicer then seabios, but as for reset, I do not think it makes a difference.

1 Like

Navi has the bug also, it’s nothing to do with being UEFI compliant


Ok, well, I know he said reset, but I thought OVMF and VFIO helped solve some of the bus issues? Or at least loading the vbios? I dunno there’s a large gap between my early experiences with PCI passthru and now. Sorry if I was mistaken that it mattered but I thought I saw posts of people having to patch the vbios to make it work with UEFI so I thought that was a thing.

Ah, so Navi has the same issue after all. Though I don’t think anyone said it UEFI? /shrug. I only mentioned that I hadn’t heard one way or another and he should check. Thanks for the update on your patch. :slight_smile:

anything from the initial launch of the HD 6XXX series and back would have to be flashed to work with UEFI. i think the HD7XXX series had UEFI support from the get go. and i know the R9 290 had it.

Does anyone know the odds of Vega 20 based blue colored Radeon “Pro” VII, also having the VFIO reset bug ??
Being a card meant for the “professional” market, is there a possibility that the same issue might not exist ?

100%, all Vega20 GPUs have the bug and there is no known workaround, The silicon is actually younger then the Vega10 which has workarounds that we are making use of.

1 Like