Which driver do I need to connect to the internet

Which mobo driver do i need to connect to the internet on my new computer, I have an as rock b75m r2.0 motherboard. Here's a list of drivers I can get http://www.asrock.com/mb/overview.asp?cat=Download&os=Win764&Model=B75M%20R2.0

Atm windows 7 can't connect to the internet because i don't have a network adapter driver or something, so once I'm able to to download the driver to a usb from my laptop and connect to the internet from my new comp i'll download ALL dem tasty drivers :P

Thanks in advance!


version 1.6

ty ill try, how do I update? its a Unix Executable File, should I put it on my usb then select it as uefi boot order 1 or something?

It's been a while since I've been in ASRock BIOS... so I can't tell you step by step... with ASUS boards there's the AI Suite II utility you can use from windows to update BIOS: download file, open AI Suite II, go to update tab, update BIOS from file, select file, and it updates...

you can also update directly from the UEFI by going into advanced mode > tools > EZ Flash Utility > (enter path to file)...

I'd imagine ASRock has a similar way to update BIOS... put the BIOS update on the computer, write down the file path... restart, press F2 or del to get into UEFI... find the flash BIOS and enter the target file path

I'm sure there's a youtube video that will demonstrate it visually...

ok, i updated it....but it still doesnt connect to the internet through an ethernet cable. I don't know what to do :\ any suggestions?

thanks! i'll try that, if it doesnt work i don't know what to do :'-[ 


there we go... download the Realtek LAN driver ver: 7048

just look which lan chip they have installed on your motherboard. I think its a realtek.

yea it didn't list the LAN driver in the "drivers and utilities" section so I figured it would be included in the BIOS update... you have to click on "list all" to get the LAN driver to display... 

Realtek RTL8111E is the chip.

so yeah DrunkenPanda´s link should be it ☺

ok, so at first i was getting the error message "realtek network adapter could not be found" then something to do with deep sleep mode every time i tried to install that pan driver. Then I updated my bios to 1.60 and did it and it worked. For anyones who does this update there bios then install the drivers.


Lol, i finally got to download windows 8 pro iso so i could put my product key in and i realised its an oem code....balls, i need to get a refund :D

Hahaha relax relax everything will be fine lol. ☺