Where is my computer failing?

So basically, I don't think my computer is performing up to standard. I'll give you a few examples of this.

Battiefield 3 @ 1080p. My FPS go as low as 40FPS while looking over a map, for a 7970 Vapor-X I don't think that's right?

Skyrim @ 1080p. While looking over whiterun from Dragonsreach, My FPS drops to 26, on the lowest settings at 1080p it's only at 40.

GTA IV and EFLC @ 1080p. I can't run either of them maxed, I end up having to turn the draw distance and details down to play at 40+ FPS.

Basically any game where there is NPC's or simalar my PC fails completely, I still get the same frames as my old HD 7770 1gb card, I've tried overclocking my CPU to 4.2Ghz and still I didn't see a change.

I have no clue what it is, I am guessing it's my CPU, but I really have no idea, It could be my RAM or anything.

Most of you will come here and just say "Switch to intel" or something, that's my last resort. As the last thing I want to do is to buy a new motherboard and a CPU.

If it is my CPU, would an upgrade to an FX-8350 be beneficial? 


I would love if someone could help me out a bit here, give me some sort of direction or anything to help improve this problem.

PC Specs:

  • FX-8120 @ 4.0Ghz
  • Antec Kühler H2O 620
  • ASRock 970 Extreme4 MB
  • 8GB DDR3 Kingstons' Hyper-X 1366
  • Sapphire HD 7970 Vapor-X 3gb
  • 750Watt Power Supply
  • Phantom 410 Mid-Tower Case
  • 500GB HDD
  • 64GB Adata SP900 SSD for Windows
  • Windows 8 professional 64-bit


Any help would be fantastic, cheers guys :D

That is extremely odd; the 8120 is a very capable CPU, and is definitely blocking the 7970's performance in any way. I would install the most recent, up-to-date drivers, and make sure it is running at the promised clocks. Install, or open up MSI Afterburner and check the clock/boost clock.

Not normal, I get higher fps than that in BF3 on my Phenom II X4 + 7850 backup rig. Do you use the latest drivers and latest BIOS, and what's your CPU/GPU temp reading? The 7970 should perform about the same in BF3 as a 680 like on my main gaming rig, where I get double that fps.

Upgrade to a 8350 will not add a lot of fps in most games, it's definitely a problem of some kind that's holding back your system. Did you do an FSB overclock? Sometimes that slows the GPU down.

Thanks for the replies guys, I am using the latest driver for everything. I have the latest BIOS update and I am running Catalyst 13.5(I think).

As for the temps.

The CPU never goes above 55C and stays at 4.0Ghz.

The GPU never goes above 60C either, and the clocks are locked, never seen them move. I have done some overlclocking with MSI Afterburner and AMD Trixx to see if it made any difference, I only gained about 2FPS, so I went back to default clocks.

My FSB hasn't been changed at all, only the multiplier, I've tried the default clocks and every BIOS setting stock. Nothing changed.

I also tried some other games:

Assasins creed III: FPS never goes above 30 in Boston(I am using the release patch)

Saints Row the Third: Same story, about 30FPS.

So every game so far, they all have a load of NPC's, and they're the ones that lag. I tested out Crysis 3 and I run it maxed out no problem, that includes multiplayer.



That's very strange indeed. I get better numbers than those on my FX-6300 @ 4ghz and GTX 560 Ti...

Well now I'm just confused.. I really have no idea what is failing :/

Sounds like you still have the multicore tasking bug on your system, did you try the AMD multitasking patch for Windoze? Strange though because BF3 is also supposed to be multicore optimised, but besides a faulty motherboard, that's pretty much all I can think of.

I'm not sure what you mean by that, but I am using the "AMD Multicore optimiser" if that's what you're meaning?

Battlefield 3 singleplayer works flawlessly though, it's locked at 60FPS on ulra and will never change, not even for a second. Multiplayer is a different story though, I get 60FPS locked then it drops to 40 ish. Pretty annoying D: