What's wrong with my USB 2.0 Drive?

Got a run of the mill 4GB PNY USB drive. File System is set to FAT32. Used it for the entirety of my CAD program when I studied drafting. Have all of my notes and everything on there. I decided I wanted to copy them all to my PC. And connecting it involved waiting around 5 minutes for the damn thing to respond.

Every action you make takes at least a few to several minutes. Opening a folder. Opening up the Properties of a folder. EVERYTHING. What the hell is going on with this thing all of the sudden, out of the blue? When I always used it, it read, transferred data and worked normally and reliably. It worked like any USB drive. Also, whenever I try and access something it locks up during those several minutes every time. Incredibly frustrating. I got a file copy error before. Now it too is out-of-the-blue GONE. When you try and copy something it calculates a mere 29 MBs and just HANGS. What the HELL is wrong with this thing? It never had this issue before.

Also, if it matters the error code I get when trying to copy, or I USED to get anyway was 0x80004005


It sounds like it’s dying. When that happens your files may already be partially corrupted when copying them.

I’d say, backup what you need and throw it out.

You should never trust a USB drive for backups, those things are built cheap.
I had this with a videofile I wanted to transfer over, the MD5Sum was different everytime I copied it off the drive. The file played fine too. I retested that with Btrfs (a linux FS) and there I immediately got an I/O error when reading the data. Conclusion: don’t trust them. They may silently corrupt.


Just like Zennoe said your USB drive is about to die so if you can make an image out of it asap and stop accessing it that would be best to not lose all your data.

For the future: it’s best to have multiple backup copies of important data and have one copy off site. There are decent sites like mega that allows you to save up to 50GB of data for free.

Yeah, cloud is convenient but slow depending on your upload.
External HDDs are a thing, too. Or extra fancy is a NAS.

Btw I just ordered a 2TB QVO SSD cause I got a notification today, that my 6 year old HDD has 8 bad blocks. Sounds not too concerning right? But no, immediately when it shows signs of failure, you should pull it out of your deployment. It can no longer be trusted as before. I might still keep games on it.


Sure. My thought process was that, along your suggestion to use more reliable media, a cloud backup can save you in case of catastrophic faliure.



Well I don’t know how i’m going to get anything off of it. It can’t even transfer 29MB of data. Based on my observations, it looks like it’s ALREADY dead. :neutral_face:


Recover from backup :stuck_out_tongue:

QVO as in Samsung QVO? I bought two 1TB QVO drives, and it’s a piece of crap. It is cheap, but super slow on write.

Yes a Samsung QVO. I won’t run an OS of it so I think I’ll be fine.

:sweat_smile: Sorry, err… How the hell do I do that? :laughing:

If it contains really critical data send it to a data recovery service.
Be warned, they are expensive.
They may be able to directly interface with the flash memory, extract the data and repair some damaged files.

Of course it will depend on the nature of the problem, but I’ve been pleasantly and frequently surprised with the success of a simple CHKDSK on older SD cards and USB thumb drives.

I’ve tried CHKDSK on command prompt. It’s completely unresponsive and doesn’t finish. This is the main thing i’m curious about. It can even lock up my PC and cause my monitor to flicker on and off. This is really weird. I’m wondering what can be done. And once again, what the cause of this is.

I used this USB flash drive for college. I took some courses and worked off of it the entire time. Adding notes and drawing files. And I even plugged it into my PC in the past. Now all of a sudden this happens.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.