Return to Level1Techs.com

What to wait for before attempting Navi on Linux?

So, ehm, I might have pre-ordered a RX5700 for use with Linux.
My list so far of what I need is Linux 5.3 (or current master branch), Mesa later than like last Thurday, and libdrm 2.4.99.
What combination was tested? And do we know what would remain to get some useable support?

I know my way around Linux as a user, and it wouldn’t be my first kernel build… but i’m a bit lost at adding a new libdrm to building mesa.

The answer, courtesy of Phoronix, is to install the pre-packaged drivers and wait for ~September.
I had exactly zero issues in doing this :slight_smile:

2 Likes

I didn’t take my own advice of waiting for September before touching anything and tried out the latest drivers (19.30). The fan speed is up to annoying levels at idle, probably similar to this. I have no RPM readout, as that requires a newer kernel… But on the flip side, power consumption is way down. Now i see values as low as 7W in (lm-)sensors, before it was around 30 at the lowest. Now the back of the GPU is cold to the touch, where before it was rather hot… this makes the minimum fan speed increase seem extra unnecessary. A friend on Arch tells me he has the higher power consumption and fan speed with a 5.3-kernel… :confused:

1 Like

I tried my 5700xt on fedora 30 kernel 5.2.8 the other night and although it doesn’t have a boot issue anymore… I can’t play games with it yet.
Will wait another couple of weeks then try again.

So, we are well in to October now, but I’m still not on mainlined/kernel drivers. Tried basically on release of 5.3 and again today. Both times with libdrm, mesa etc from the Padoka PPA. First time around it froze an otherwise functional-looking lightdm, and now it just gives artifacting instead, and later proceeds to make teh system unresponsive even over SSH. Fortunately, that does not occur when using the iGPU, even if the RX5700 is still in the system and its kernel module loaded. Not sure how i want to proceed, any tips would be greatly appreciated.

Oct 06 19:57:09 obsidian kernel: [drm:amdgpu_dm_commit_planes.constprop.0 [amdgpu]] *ERROR* Waiting for fences t
imed out or interrupted!
Oct 06 19:57:09 obsidian kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx_0.0.0 timeout, signaled seq
=2, emitted seq=3
Oct 06 19:57:09 obsidian kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process Xorg pi
d 1419 thread Xorg:cs0 pid 1484
1 Like

Even Radeon VII took a while to be supported properly and that was basically just 7nm Vega60. So a radically new design like Navi will take a while. This was one of the reasons I got another Vega card not long ago. (Price being the other major one.)

I tried a build last week with Aoerus X570 and RX5700 on Ryzen 5. I used a Manjaro, because i had no time to setup e new Arch System from scratch. With the last Manjaro Iso, i could not get a Graphical Interface. After i applied the Updates of the Arch Wiki Navi10 Article, it works fine. I don’t play too much, just experimenting. Cities Skylines works, Dota 2 works,… Now i am working on Wine, Anno 1800, no luck yet, freeze when calling DXVK. On Unigine Heaven 1080p i get “only” around 3000 points, fps between 80 and 120 on Ultra. It seems a little low for imo, somebody has any results yet?
Greets, Daniel.

And today mesa 19.3 dropped in the Padoka PPA. Insatalled it, working fine so far. Games start and run, but i get the feeling they are running a bit slower than they used to with the pre-packaged driver. However, i must be imagining things, as the game says it’s doing 299FPS.

1 Like

I just tried the ubuntu 19.10 beta. No luck e.g. on Unigine Heaven yet. Installed the oibaf Graphics drivers ppa.

For desktop use, no problems… :slight_smile:

Hm… Trying…

1 Like

I settled for ubuntu 18.04 and the AMD driver. Installed the pro version and games works. Dual screeens as well 2nd display in porttait mode. Have to run non wayland with video for a few resizings issues.

Its early adaopter working.

I am kind of waiting for fedora 31 and back to all amdgpu but its on kernel switches at the moment and I have never got dual displays to work.

1 Like

OK. Do you have games running on 18.04 with lutris (Wine, DXVK)? Because that didn’t work out over here…
Or only nativr Linux Games?
What Heaven Benchmark do you get?

I am waiting on info on this as well. I really want Navi, but right now I’m sticking with the Vega 56 until the drivers for Navi work properly in Linux.

I am running latest Arch kernels (non LTS) and I keep hearing from folks that even this isn’t stable enough at the moment.

kind of disappointed at this launch after Vega went so well

maybe I should try installing fresh again, but kernel 5.3.5 on fedora 30 is giving me 1 FPS in rocket league at 1080p (and the CPU on the 3700x is at 50% idle on the desktop and 100% in game)

so something isnt right… guess I can try F31 beta.

1 Like

Unigine Heaven Benchmark 4.0

FPS:
92.1
Score:
2321
Min FPS:
47.8
Max FPS:
191.5

System

Platform:
Linux 5.0.21-050021-generic x86_64
CPU model:
AMD Ryzen 7 1700 Eight-Core Processor (3792MHz) x16
GPU model:
Unknown GPU (256MB) x1

Settings

Render:
OpenGL
Mode:
1920x1080 8xAA fullscreen
Preset
Custom
Quality
Ultra
Tessellation:
Extreme
Powered by UNIGINE Engine
Unigine Corp. © 2005-2013

Superposition

Rise of the Tomb Raider 1080p High preset

Ive mainly been playing through Dragon Age via proton and that works too.

1 Like

I got 1014 in Heaven, but that was at 4K which is my resolution of choice. I threw it out as Unigine claimed there was nothing much to compare with, and proceeded to run Superposition, in which i scored 5239, which is basically GTX1070 levels.


The game i referred to previously was HL2. Not sure i have any DXVK games in my Steam library, but I’ll try to find out.

Anno 1800 is now running… :)))
(Lutris)

Don’t know exactly, why… perhaps some update in mesa-git or similar… 5.3 Kernel

The Heaven Benschmark is like mine (around 90-120fps, Result: 2400-2500). I wondred why it’s somehow low… i saw benchmarks online above 10.000???
I mean, it is kind of the best hardware you can get right now…