What am I doing wrong? New build w/ ASRock TaiChi x370 & Ryzen won't boot

This is my third build. The last was three years ago, and the first six. So I’m a noob++. I’m not sure what’s happening here, but I"m confident it’s a user error.

Here’s my parts spec: https://pcpartpicker.com/list/yZQkBP

I’ve carefully followed instructions, but cannot get the board to boot. It gets power and its fancy violet/blue RBB LEDs pulse, but the CPU and fans won’t start. I have the RAM in the second and last slots and connected (as far as I know) all of the power from the PSU.

Any help is greatly appreciated.


I would start by removing all unnecessary components, while retaining the PC’s ability to boot to BIOS.

You need:

  1. The mobo. Make sure you have both the 24-pin main power and the 8-pin CPU power connected.

  2. One stick of RAM.

  3. Power supply.

  4. CPU, with cooler.

  5. One GPU.

If that boots, add in the SSD and install windows. Then add in the rest one by one.

Side note: Holy crap! The power delivery on that motherboard… that is insane.

1 Like

Reseat the CPU.

what was said above, also if what stconquest said does not work after step one, try switching the ram slot and switching the ram stick as you may have one or more dead sticks or slots. step 2 of nothing works is to swap 1080ti’s incase you have a dead one.
if you still have this problem rma everything

Do you have a speaker plugged into the board so you can hear the beep codes? If you have an old case around you can rob one out of it. If not you can pick up a cheap three pack. I don’t know why manufacturers quit including them.

Double check powersupply connections. Make sure the 8 pin EPS and 24 pin is securely plugged in. Does the Dr Debug (two digit number output near the bottom of the board) light up on the Taichi?

Yes, it reads 48.

From what I found here: http://www.asrock.com/support/faq.asp?id=334

That means:

Problem related to memory. Please re-install the CPU and memory then clear CMOS. If the problem still exists, please install only one memory module or try using other memory modules.

So I swapped the RAM around, reseated the CPU, cleared the CMOS (which is not so easy to find on this board) and success!

Many thanks!


Might still be worth running memtest86 to fully check out your ram if that was causing it. You may have just moved the problem around! Still, at least it boots now.

1 Like

Clearing the cmos is allways the second thing i personally try,
if i doubled checked all power connections and such.
Taking the bios battery out to easy clear the cmos, sometimes does magic. :slight_smile:

Last question: I’m attempting to boot from the SSD from my old rig. The OS is Linux Mint. In BIOS, In the ASRock BIOS, I’m not seeing any options for drive boot(s). What am I missing?

Can confirm. Intermittent problem I ran across not long ago was solved like that.

Do you have a BIOS boot menu, where you can select the device on boot? Usually holding down F11 brings this up. See if you can see it there.

If not, maybe check you have legacy boot device support turned on in the BIOS?