Weird red shift during recordings of State of Decay 2 with Nvidia Shadowplay

So I’m having an annoying bug? I guess? where everything in game is really red and oversaturated. I have messed with all the options in game to no avail. I want to upload this to YT. Any thoughts?Processing: Dayton (State Of Decay 2) 2021.10.27 -…

While I don’t have a solution, testing is always good.

Have you tried any other capture/recording software, OBS, Twitchs own thing, xBox Game DVR… other stuff too that I can’t think of.

That would at least start to narrow it down if any of them are different.

EDIT: Where did you buy it as I see different versions have different DRM.

While PCGamingWiki does not turn up anything odd in issues fixed, it did link to this external settings editor fir the game that give far more control, not sure it is useful at all but it is something to look into.

thanks Zilbob, will look at this later, after I test with OBS.

1 Like

I agree with this option, try a different recording software to see what it does. Also I am going to assume that it’s not that red on your display while playing. I use shadowplay/whatever they call it now in the nVidia overlay now, it’s not actually called Shadowplay in there, and I know there’s no options for saturation or filters or effects.

For an easy free way to check, download VSDC screen recorder and see what that produces. If you get the same thing, check your nvidia control panel settings and see if something got changed there.

1 Like

I have checked the nvidia control settings, and you are right there is nothing to change there and nothing has been changed. One of my friends that I mod for uses OBS to record the game and he doesn’t have issues. Only problem is I haven’t ever used OBS.

1 Like

That’s why I recommended VSDC screen recorder :slight_smile:

well I just did a test stream with OBS, looks like that’s what I’ll be using.

1 Like

Good to see that OBS worked for you. I’m still interested to find out why Shadowplay is introducing a red tint to the recording.

1 Like

I have no idea. there was literally no option to even try and change anything that could affect the recording like that. An oversight on nvidia’s part IMO. I will be using OBS in the future for this game it seemed to fix the issue perfectly.

1 Like

Thats good you have a workaround, it does leave me wondering though why ShadowPlay did that. I would love to know, just to know, but at least it works.

If i remember, I will reinstall SoD2 tonight and try to record it with shadowplay and see what happens. What GPU are you using?

3060 TI. it should handle everything I can throw at it.

Ok, I’m running a 2060 OC. I was just wondering if it’s a hardware issue when I get my test recorded.

1 Like

did you test it?

could be you have your nvidia control panel set to let nvidia control the colour gamut.
open your nvcontrols and check the adjust colour/video and make sure its on video player settings.

there’s also yuv YUV - Wikipedia which can cause colour shift if enabled on a stream/video that doesnt have it.
so worth looking into your chosen codec settings.

I didn’t get a chance, I had a video to edit for upload … i’ll get to it soon

1 Like

I checked mine tonight. The recording looks fine.

1 Like

so weird.