Return to Level1Techs.com

Weird Problem: Known Good/Compatible RAM Module Does Not Work in Thinkpad L380

If anyone can shed some light on this, I’d really appreciate it.

I ran into a very strange problem with my Thinkpad L380 recently.

The laptop originally came with a single 8 Gb stick of DDR4 memory, which I supplemented with an additional PNY 8 Gb module (From Best Buy) after a few months of owning it.

Fast forward a year and I purchased a Lenovo Legion 5i to replace my gaming desktop. Again, this machine came with an 8 Gb module.

I decided to move the extra 8 Gb from my L380 to the Legion laptop since the latter would probably benefit more from the extra memory.

Eventually, I went out and bought another 8 Gb PNY stick from Best Buy to bring my Thinkpad up to 16 Gb again. I installed the module, pressed the power button and got an error code saying there was a problem with the memory. Thinking it was just a bad module, I returned to best buy, exchanged it for another stick (same sku) and put the new one in my Thinkpad, which again, wouldn’t turn on and threw a memory error.

Tried the new module alone, in both slots of the Thinkpad, no dice.

But then I tried it in the Legion for gits and shiggles and the thing worked perfectly.

So, TL/DR (I don’t blame you): A known good memory module identical to one that works in this computer doesn’t seem to be compatible.

The PN for the module that doesn’t work in the thinkpad is 8GBU2X04JGGG39-12-K

The PN one that does is 8GBU1X08JGGG39-12-K

Both are 8GB DDR4 2400 PC4-19200 CL-17-17-17-39 1.2V DIMMs and both work in the Legion 5i

They were bought about a year and a half apart.

Is the Legion the Intel or AMD version?

Looks like the new module is dual rank, and the older one is single rank. The memory controller in the L380 probably doesn’t like mixing ranks in dual-channel mode. If the bios allows it, you could see if you can force single-channel mode, and see if it boots.

1 Like

The Legion is Intel

Okay that rules out my idea, AMD can be Choosey about ram, but usually just with regards to speed, not outright working or not working, sorry.

I don’t know bud. Looks like they’re not identical to me.

Note the 2X04 and 1X08 in the model number. That’s the rank and module size.

1 Like