Weird Linux Gaming Discoveries

Figured I should probably have a thread on these, since I’ve been discovered a few. I might as well document fixes that work and fixes that don’t, in my context, too. As mentioned elsewhere, I’m running Arch Cinnamon, with a semi-custom version of the Zen kernel.

Currently I’ve got a few that I’m trying to figure out:

Space Marine Anniversary

  • This just crashes at launch.
  • Issue seems to be CEG anti-cheat, which is only relevant for multiplayer (which I don’t care about, or this would just be a “wait for hardware for Looking Glass” entry. I have a couple of those sadly.
  • I am aware of one supposed fix - but it’s not one I want to employ.

Inquisitor: Martyr

  • It just works (under 6.18-GE-2 anyway) at least, mostly, but
  • Crash when alt-tabbing is immediate, at least under fullscreen. Borderless has some strange behaviors.

Games I’ve already solved:


  • I needed a VM for modding tools. I can’t stand Skyrim unmodded.
  • It works, it’s stable, it’s fine. Once again, however, needs a GE Proton build (to avoid sound issues of all things)
1 Like

I know what you mean; but its surprising how many people refuse to mod skyrim outside of Bethesda’s store dlcs (I won’t even buy any).

Waiting on a VR headset so i can mess with Skyrim-vr one more time. I normally use Mod Organiser 2 for modding, and its not always easy to get running right (impossible for some people).

Sadly I think the new Skyrim release (has store dlc and updated engine?) doesn’t include VR (why didn’t they just bundle it all together?)

If you figure out the Space Marine fix please post. I downloaded it last week and was disappointed to say the least. I am on the verge of re-installing a windows partition…

CEG is Valve’s DRM, not an anti-cheat. its an anti-piracy measure.
Valve seems to have no intention on supporting their DRM on their platform on their OS (SteamOS).

I had to actually go with Vortex due to the way MO2 handles filesystem access. Sadly.

Pretty sure the fix is just to use a pirated exe without the copy protection at least according to protondb, I re-installed it a couple weeks ago but haven’t gotten around to trying it out yet.

Get use to using this website: Book mark it now!

READ past the top comments; it does work with tricks (maybe drm free exe).
Most people don’t even attempt to get games working, it either does or doesn’t.
Linux is all about work arounds, its getting better but not there yet. Still need to jump through some hoops!

There may be apps to remove CEG from the exe; I’ve used such apps before on Valves DRM so I don’t know if its the same. (when wanting to run a game without steam.exe checks because its a pain in the butt under wine)

I’m also frustrasted by an older CEG game; COD:MW3 single player / spec-ops.
the multiplayer has been worked around and seems okay, but singleplayer still not launching.

this has been suggested on the protondb, but I’d rather wait and see if anything changes CEG side.

You need to read up on Valve github; is there any suggestion they are looking into fixing CEG checks under proton? otherwise you could be waiting a lifetime!

1 Like

Yeah, looks like I won’t get it.
The steam deck was the only hope on that side, as it “would play all the games”

If nothing develops from that, I’ll just move on.

Have you properly read through this link

Someone mentions they get CEG games working via WINE with Steam running inside wine and launching game that way (like with Lutris).

Steam.exe can have some graphical glitches run via Wine so you may need to fiddle a bit, I think there is a minimal steam launcher argument as well.

If I had a CDKEY I’d test it myself… BUT I won’t be spending money.


Yeah, I am well aware of protondb and I understand that cracked.exe is currently the way to do it but I am extremely hesitant to use that workaround on my main computer.

For starters I just said there may be other legit work arounds.

AND second of all proton/wine is containerised, your NOT running the game directly on your OS… once you delete the prefix, the machines ID is gone forever… think of it like a pseudo-virtual machine!

Hopefully Valve team sorts it out soon. Seems a tad odd since it works fine if you run game via wine method. Give that a go, no crack needed.

I’ll give this a shot sometime soonish. Thank you.

That is not entirely true.

Wine is NOT a container, it doesn’t isolate anything. It’s just an abstraction layer between the windows application and Linux.
Wine, and therefore the applications running in it, have access to the filesystem because wine mounts the root filesystem as one of its “windows” drives.

There were attempts for containerization in the past, but I don’t know if they got anywhere.

This seems to be one of the very few occasions where Lutris’ winesteam runner actually still has its place.
winesteam runs a windows steam installation inside wine (as opposed to how Proton acts outside of steam), so those checks might work in it.
The new steam UI gets more and more broken in it with each Steam update so you’ll probably have to install using the (windows) steam commandline options, and that’s also what Lutris does.