VNC wont connect to virtual machine

So tried to force myself to use command line only by running Fedora 25 server.
I got everything running and installed the virtualization package.
Added my user to libvirt group.
Using this command
sudo virt-install --name Unifi --os-type linux --ram 1024 --vcpus=1 --disk path=/Tank/Unifi/unifi.img --graphics vnc --cdrom /Tank/ISO/ubuntu16.iso
I run this command over an ssh connection to server through my vpn to house connection where server resides.
Then from laptop I try to connect through tigervnc to ip address to machine on port 5900. I get connection refused.
I am running everything network wise through my bridged connection.
I have run nmap and after command port 5900 is open.
Firewall and Selinux are disabled.
I have also set qemu to allow vnc to listen on
Is there anything else I am missing.
Also through my openvpn connection I have full access to all machines on my pfsense machine. So i dont think that is my problem. I checked pfsense firewall logs and dont see anything being blocked there.
Also if i run this command without sudo i get this error.
ERROR internal error: /usr/libexec/qemu-bridge-helper --br=br0 --fd=24: failed to communicate with bridge helper: Transport endpoint is not connected
stderr=access denied by acl file

Have a look at this maybe

I tried that and still connection refused.
On a positive note i can run virt-install without sudo. I am at a loss. Is there something stupid I am missing.

what about using spice and virt-viewer?

what can i use for spice on windows?

Oh.. I see.. er. Google says this..?

Yeah sorry for dumb question very frustrated at this point. I think I'm going to go back to fedora 25 workstation where I had everything working and get everything set back up and see what the files look like after that and see what I am missing. It just seems ridiculous that it is refusing connection even though port is there. I'll report back soon and let ya know. I guess one more question is anyone using bridged connections or are ya just using the virbr0 connection and connect to them that way?

I think mine are just virbr0. need to check. but im just connecting to mind from a local F25 machine to vms on that local machine via spice

And also my Windows PC is on same subnet as server so that eliminates something in pfsense I would assume.

I had this all working with a bridged connection under f25 workstation. Can you check and let me know what you are using just to help me figure out if I'm an idiot or something is borked on my machine?

I can but will have to be later as im going to attempt to sleep

No problem appreciate the help

So i have done everything i can think of. Im about to nuke machine wipe all drives and start over with Fedora 25 workstation and virt-manager and get some stuff going and then look at files and see what I am missing or screwed up. I will just force myself to use command line over an ssh connection as much as possible and fall back on virt manager for when i really need to get something done.

@Eden did you ever get a chance to see how your server is set up. If is using the default virbr0 network how are you talking to VM's that need to get out. Lets say like a Unifi COntroller vm, Git server, Zoneminder etc.

Ok well not to be the only one here but may be of some good info for someone down the road.
so i nuked everything on machine and started over with Fedora 25 server. Installed virtualization group and went to add my bridge under virt manager and it would not see my main nic an Intel i217-lm in a dell t20. So i loaded in an intel pci x 1Gb card and it saw it after telling network manager to forget all settings for it. I am wondering if there is a bug or may even be part of the design that virt-tools want a separate nic for a bridge... I may be way off base but now I remember that when I had this all running before I was using both of these nics in same configuration. I havent tested the vnc portion or even gotten in vm running yet so I will post back with what I find and hope this is useful to someone since i have spent 3 days trying to figure this all out.

IMO libvirt is not an elegant CLI tool

The binary is called something else in Arch, but their wiki gives lots of info

1 Like

Appreciate that I guess I never took the time to differentiate between the two.