Return to Level1Techs.com

Virtual Machine Manager error messages

helpdesk
#1

I am dealing with multiple issues during Vm creation.

1.when I choose media for installation (local) and browse to to the iso every time even I downloaded different

Win 10 iso it cant detect the iso. I untick and tick again the box and still getting no detected message. Only way to bypass this is uncheck

the box and type MIcrosoft… then it autocompletes Windows 10. Why is that??

2 In step 4 which I have to select storage for the VM, what to choose when I just want to passthrough an ssd disk which is upon a pci controller?

3.In final step (5) and before I press cistomize configuration before install, the tab Network selection has by default Virtual network ‘default NAT (inactive)’ Never the less when I press customize conf or finish displays a message that the NIC is not active Would you like to start the network now? Of course I press yes. After that no matter what I do with the VM if I shut it down then its impossible to start it again with the below message

Blockquote
Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 75, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 111, in tmpcb
callback(*args, **kwargs)
File “/usr/share/virt-manager/virtManager/libvirtobject.py”, line 66, in newfn
ret = fn(self, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/domain.py”, line 1400, in startup
self._backend.create()
File “/usr/lib/python3/dist-packages/libvirt.py”, line 1080, in create
if ret == -1: raise libvirtError (‘virDomainCreate() failed’, dom=self)
libvirt.libvirtError: Requested operation is not valid: network ‘default’ is not active

Bottom line is each time the whole host system freezes cant do anything except shutdown or if I press ctrl+alt+f4 (remembered that from windows) it puts me to cli and asks for log in

0 Likes

#2

I’m not even sure what you’re talking about so lets just go through the New VM wizard in Virt-manager.

Step 1 of 5
Select ‘Local Install Media (ISO image or CDROM)’ and click Forward.

Step 2 of 5

  1. ‘Choose ISO or CDROM install media:’, Click the browse button to the right.
  2. A new window entitled ‘Choose Storage Volume’ should appear.
  3. It might be hard to see if you have a dark theme like I do, but there is a ‘+’ button in the bottom left that has a tooltop ‘Add Pool’. While not strictly necessary I’d crate a new pool called ‘ISO’ by clicking it, providing a name, and finding the directory the Win10 ISO is located (leave type at the default - dir: Filesystem Directory). You might want to move the ISO some place if it’s still in your download directory. Where is up to you, but the idea is to have one spot with all the ISO’s you might use when creating VMs.
  4. Now that you have an ISO pool in the left hand list simply click on it.
  5. If you do not see the Win10 ISO in the list of volumes on the right, click the refresh volume list icon above the list. Click on the ISO and then click choose volume in the bottom right.
  6. Leave the Automatically detect checkbox enabled and hit the forward button. If it fails to parse it, it’s not the end of the world it’s purely informational and you can manually enter Windows 10 if all else fails. It worked for me but I might have renamed the file into something human readable out of habit.

Step 3 of 5
Pretty basic. Set how much ram and how many vcpu’s you want in your VM and click forward.

Step 4 of 5 - Storage
Since you want to pass through an SSD and I assume you’ve already made sure the controller it is attached to is both isolated on it’s own IOMMU group, and has the vfio-pci driver loaded… just uncheck ‘Enable storage for this virtual machine’ and click forward.

Step 5 of 5
Check ‘Customize configuration before install’ and leave the network selection alone for now (if you continue to have problems with the network I’m assuming there is either permission issue or there is something extra you need to setup on your distro for libvirt to create/start the network for you. Check their wiki or forums for solutions.). Click Finish.

Customize Screen

  1. Click ‘Add Hardware’ in the bottom left.
  2. Select ‘PCI Host Device’ in the left list.
  3. Select the host device that matches the controller with the SSD that you previously prepared to be passed through and click finish.
  4. You should now have a new item in the left list with the device address of your controller.
  5. Click on ‘Overview’ on the left list, verify that the chipset dropdown is set to ‘Q35’, and firmware dropdown is set to ‘UEFI x86_64…OVMF_CODE.fd’.
  6. This should be the bare minimum config you need to ‘Begin Installation’. However, I’ve never installed on a passed through drive so ymmv. If for whatever reason that fails and windows doesn’t see the disk, I’d just follow the guides suggestion and use ‘virsh edit’ to add the drive as a raw device.

DO NOT add the GPU right away as you’ll just complicate things. Just use the virtual graphics until you get Win10 installed.

If your machine locks up at this point you’ve either not gotten something setup right from the previous steps or have a hardware issue to chase down.

2 Likes

#3

Thank you for goingf down all the steps again but I had specific problems in specific step. Since I ve done all of what you ve mentioned exactly and still cant continue with installation or even if I manage to continue it will freeze the system as I originally said. Thats why I wanted someone to remotely check the system and the configuration.
Other than that i wrote down the erros I am getting . If it was so easy to go through via wikis in a such plethora of information I would have done it without me asking here. So even i dont mess with the nic card it keeps preventing me next time from starting the VM (i have put my username in the virtual manager user team)
Finally the second iso with the virtio drivers is best case use scenario when?
-for instance you have a virtual hd . Is it only for hdd ? (Because in proxmox through these virtio drivers after installtion you needed that balloning, numa …etc)

ps I didnt use the gpu just yet Even this way I cant create a damn VM something which is extremely easy in virtual box on Win.
I cant comprehend why everyone is so happy about Linux being so user friendly and stuff. It just aint. I was there from version 9.0.4 or maybe earlier version and remember myself struggling with drivers multimedia codecs. Hibernation…and stuff like that, Through the years ok it became more straightforward in drivers at least but virtualization is wayyyyyyyyyyy ahead of becoming user frindly experience, I ve set up proxmox at once with multiple vm’s, Open media vault and unraid. This damn Debian 10 refuses to work as it should. But its difficult situations that I like, I jsut always like to know why it doesnt work more than works out of the box. That is why I am still trying . A little help on the way to correct mistakes upon configurtation of course is more than welcomed thats why I am here

0 Likes

#4

so you are saying you did start fresh from the begining, and follow @Novastark 's instructions through?

0 Likes

#5

Well, best of luck to you but I refuse to help someone who acts as though I’m doing them a disservice by not being at their beck and call as technical support.

0 Likes

#6

No hard feelings. I understand what you are saying. Thanks for helping though.

0 Likes

#7

Not exactly there because each program I install I reboot and I am searching for error messages. Now I dealt with
<< failed to Start Raise network interfaces see systemctl status networking.service for details>>
and I am stuck at this one
<<[3.202732] [drm:amdgpu_pci_probe [amdgpu]] <> amdgpu requires firmware installed
[3.202020] See https://wiki.debian.org/firmware for information about missing firmware>>
Already tried read this link https://wiki.debian.org/How%20to%20install%20official%20AMDGPU%20linux%20driver%20with%20kernel%204.19.x%20on%20Stretch%20and%20Buster
but way to tech-ie for me

0 Likes

#8

sudo virsh net-autostart default

reboot

0 Likes

#9

the whole pc has been rebooted as well?

0 Likes

#10

Is this command for the cant start/raise network error? Does it make a permanent change to some conf file?

I managed to bypass that by editing etc/network/interfaces and commend the line source /etc/network/interfaces.d/* (because if you open that file it was empty)

0 Likes

#11

Your original post is chaotic. It’s hard to tell what’s actually going on. You should join one of the discords that deal with this ex: https://discord.gg/JyyFnf

0 Likes

#12

Why chaotic. I explain exactly what I am dealing with and give outputs as well.

issue of step1 of the original post is pretty straight trough . I still encounter this but I just type the Microsoft Windows 10 and I am able afterwards to press next (else it doesnt let you) . Tried also with a new iso of win 10 pro 1903 but nothing it cant detect it. Maybe an earlier version wouldnt have that bug but I didn t try

issue 2 of step4 of the original post I ve been told that I dont have to use storage if I am about to passthrough the ssd. Of course the main issue here is that the ssd is on a controller so first i passthrough the controller and afterwards I have to add the ssd to the configuration

issue 3 of final step5 of the original post
I solved that by myself. Had to comment the line source /etc/network/interfaces.d/* in the etc/network/interfaces

So why is that chaotic? I presented them as I issued them. And it was many as you can see and I am still to finish…

Bottom line is that without pass through and clean installation managed to create a vm (simple one) and restarted it many times without the nic card error of not being initialized.

I dont know about this … is it a forum??

0 Likes

#13

…and the chaos continues!!! After the fresh installation and installing the appropriate virtualization packages I checked each step with reboot for any error messages.None. So I went through and created a WIn10 VM with the most basic of options and it worked.
THe problem with the initialization each time of the network solved first by entering /etc/network/interfaces and comment out the line source /etc/network/interfaces.d because that file was existent and empty. IT seemd to work a couple of times until the error initialization msg came up again. Then I tried the @pantato method sudo virsh net-autostart default and it worked again.
SO it was time for the next small ste. TO pass through the ssd wich is on an ASMEdia controller. I followed the advice of few mentioning its so simple that you only have to pass through the pci host inside VM Manger with the configuration options. Did that but had errors many of them. SO next step to enable intel_iommu=on and during restart still no errors and tried again to pass through the pci device (ASMedia) same problem. I thought then to try the pop os method with the script and since the pci device I wanted was in its own iommu and still errors. I managed to bypass one of them by disabling apparmor (edited the path /etc/libvirtd/ I open the file qemu.conf and comment or uncomment the below line
#security_driver = “selinux” from its original form to “none”) That alone loaded the VM but each time it freezes the whole system and needs to hard shutdown. Which means I m back in my first attempt which had the same exact problem
Now I have the same problem during boot (but continues to boot after a while)
[0.07005] DMAR: DRHD: handling fault status reg 2
[0.070011] DMAR: [DMA REad] REquest device [00:1f.Z] fault addr … fault reason 06 PTE Read access is not set
New edit about the above error (I went and revert all the steps one at a time and the error went away only when I removed the VM from the Virtual Manager)
So I thought to check once again the hardware capability for VT-d / Iommu. IN order to short that long message I m giving the link https://greenpcgamers.forumbee.com/t/18aajc/dell-presicion-t7600-and-iommu-support from which you can see that it has the appropriate support (I think because intel’s info page about c600 chipset is controversial between c600 /x79 chipset.)
Some other commands and outputs you may find useful
iommu support commands.txt (2.9 KB)
as you can see here I m missing a fusion module

info about the controller I am trying to pass through
ASMedia Etron.txt (418 Bytes)
At this point thought that the controller is also clamed during boot by the host OS so thats why the VM Manager freezes but I cant blacklist it because it uses ahci kernel module which is being used by the onboard motherboards controller as well.

So if someone is able to remotely check this haunted system I would appreciate it. Its being several weeks with no success and cant stand it anymore

0 Likes

#14

why are you trying to passthrough a SATA controller? All you need to do is add a custom storage device in virt-manager and point it at /dev/sdX . I would unbind that controller from vfio it’s probably screwing up a lot of things.

0 Likes

#15

You don’t know what Discord is? It’s the chat program everyone and their mother uses nowadays. Sign up and join that room I linked you and you’ll get all the help you need. I’m on there as well.

0 Likes

#16

No I didnt but Ill check it out. Thanks

0 Likes

#17

The reason is … because in my wrong-right opinion in order for the guest OS to see the ssd needs first to see the controller which is pci-e based. At least none told me the other way around. Also the pce-i controller has except two sata ports two external usb ports useful for keyboard mouse usb sticks …etc for the guest

0 Likes

#18

Please abandon this thinking until you have a properly running VM. You CAN do it, but it is an advanced method with some pitfalls. The only thing you need to passthrough via VFIO for now is your GPU. The rest you can simply add as individual devices with your virt-manager GUI. You are creating a lot more headache for yourself than you need at this point.

1 Like