Virtual Box crashes everytime I try to I go to open a file

So when I go to open a file explorer in virtualbox, such as when I go to select a iso file to install from.

Is it up to date. Why dont you use VMware player or qemu?

Yes I am up to date. And to answer the other question, really because I have always used this, and haven't really used anything else.

O ok. I would try to reinstall virtual box. I would also give vmware player a try. I have used virtual box in the past and it feels the same but it was on windows. What distro are you using by the way.

I have tried reinstalling. I am currently on Ubuntu Gnome.

Is there a special character in the file name? See if the iso shows up in this file "~/.VirtualBox/VirtualBox.xml" If it does delete the iso name from the file. The iso also might be corrupt also. I had a corrupt iso and vmware workstation would lockup for a few seconds.

It happens anytime I try to open nautilus, not when it needs to read the file.

@Tex Have you tried removing the file using the terminal since you can't open Nautilus?

Thanks for the help guys, but I have had a couple of problems with Ubuntu besides this, so I just went a head and installed OpenSUSE Tumbleweed. Been hearing Bryan Lunduke talk to much I guess. But yeah it works fine in OpenSUSE for me.

1 Like

@Tex Great man glad to hear it! I actually just got my Tumbleweed installs setup on my laptop and work desktop yesterday and today (respectively). It's been a joy to have everything running pretty much seamlessly, hope you enjoy the distro!

You might be able to help me out here then: