Return to Level1Techs.com

Virt-Manager: Snapshots disappeared after export/import

I am running Virt-Mangager 2.2.1 on Linux Mint 20.0. I am trying to determine how to export/import a VM, so as a proof of concept, I made a POP OS VM which had 2 snapshots and ran:

virsh dumpxml pop20_04

to export a copy of the XML file.

Then I deleted the VM from virt-manager (but did not delete the QCOW2 file).

Then I ran
virsh define pop20_04.xml && virsh start pop20_04

The VM Started fine, and was usable, but when I went to view the snapshots, none were shown by virt-manager even though the file still contained 2 snapshots. As shown by:

$ sudo qemu-img info /path_to_qcow/pop20_04.qcow2
image: /path_to_qcow/pop20_04.qcow2
file format: qcow2
virtual size: 20 GiB (21474836480 bytes)
disk size: 23.8 GiB
cluster_size: 65536
Snapshot list:
ID TAG VM SIZE DATE VM CLOCK
1 Protective_snapshot_1 0 B 2020-07-16 19:03:33 00:00:00.000
2 snapshot1 0 B 2020-10-16 15:47:36 00:00:00.000
Format specific information:
compat: 1.1
lazy refcounts: true
refcount bits: 16
corrupt: false

I also tried to recreate the virtual machine by importing the orginal file from the virt-manager GUI, but still no snapshots were show.

In both cases I tried the “refresh” but it did not load the snapshots.

What do I need to do to get the snapshots back? Clearly they are still in the QCOW2 file, but they don’t reload into virt-manager automatically.