Video TS files issue in Windows 7

First of all my apologies if this is posted in the wrong section, but it seemed the closest to being appropriate. 

So I have a bunch of video_ts files which together make up a baby video ripped off a dvd. When played individually with vlc player, they work fine except for that the progress bar does not follow the video, its just empty. They play through to completion if not skipped through, and when a new point in the file is selected, the video skips and studders, while vlc flashes yellow on the progress bar. After this the file must be closed and re-opened, and left to play through without skipping to finish, and these are the only files on my computer that behave this way. Secondly, when any of the files are placed into Sony Vegas 9.0 or 'any video converter', they display as only 10 seconds long each, when infact each is about 45 minutes. Backtracking to the actual burning process, I cannot for the life of me remember which program I used, as I downloaded it just before the rip and deleted shortly after, thinking everything was fine. I realize re-ripping is an option, although I would prefer to avoid it because the dvd is a half hour away in storage..If the problem cannot be sorted with the files I already have, can anyone recommend a good dvd ripping program that will rip to a simple AVI format? I don't need the dvd menu file that the video_ts format gives.

Thank you in advance!

EDIT: The program used was 'Free DVD Decrypter'

this the sorta thing your after?

or have your just tried renaming the file to xxxx.mpg rather than _ts?

EDIT: or this one

Thanks for the suggestions! I apologize but I have no need to try them now. Before I checked back here I came across a program called 'AutoGK' that solved my problem perfectly. For anyone else interested, it can be found here- 

Totally free program. Encoding takes awhile but its hassle free and takes care of everything. Just point it to the 'Video_TS.vob' file inside the folder where all parts are contained, and let it run.

Oh yes, I actually had tried renaming to xxx.mpeg and it didn't do a thing, files still behaved the same way like that.