Video but no sound on AMD apu Ubuntu 12.04-13.04

I have recently been trying to build a HTPC I chose a apu (A6-5400K) with a gigabyte motherboard.(GA-F2A85XM-HD3). I am unable to get any sound out via the hdmi port . The port is not listed as an audio device. I was hoping to use Ubuntu for this I have tried both 12.04 and 13.04 with no change. I have tried multiple ways to install the drivers but I have not had any luck. I have also tried running with a 7790 I had kicking around so I wonder if this is a known AMD issue?

This is my first build with Linux so I have no issues moving to another distro if there is better support somewhere else. If anyone can tell me what's going on or offer some ideas for a fix or even a distro to move to it would be appreciated. 

Thanks in advanced,


All I can say, since I have no experience with Ubuntu and HDMI sound, is that the HDMI audio output on my 7850 works perfectly fine with Manjaro, Arch, Gentoo, Fedora 19 and OpenSuSE 12.3, also with a Gigabyte mobo. I use both ALSA and Pulse, both work without issues.

The only sound issue I've noticed is with the mixers when switching by simple session relog from KDE to a gtk-based DE, but that's to be expected.

Thanks a lot man I will try out one of the distros you listed.

Any of them more noob friendly then others?

Manjaro is the most new linux user friendly. It is just bleeding edge enough to have all the functionality that is available with AMD GPUs. Most things are preconfigured, and there is almost no breakage notwithstanding the pretty bleeding edge character. For latest AMD functionality, switch from the 3.4LTS kernel to the latest kernel with "mhwd-kernel linux311" if you're going to use radeonsi and "mhwd-kernel linux310" if you're going to use catalyst.

OpenSuSE is also pretty user friendly. I do use tumbleweed, which is sometimes a bit more complex, but you can go for a more bleeding edge system.

Fedora and Arch are enthusiast grade, but if you don't need advanced functions in Fedora and use Fedora Utils and Yumex, it's also pretty userfriendly. If you do use advanced features, Fedora does some things differently, and an advanced understanding of linux is required. Both - especially fedora rawhide - are very bleeding edge, and if you chase the latest and greatest features all the time, some breakage, especially with arch, is to be expected. Fedora is remarkably stable for being the most bleeding edge distro of all, but if you use advanced functionality (which is why one wants to use fedora in most cases, fedora is the most feature packed distro for enterprise, engineering, research, scientific and development use), you will need some serious problem solving skills, and preferably also a powerful computer with full VT-x+VT-d/AMD-V+AMD-Vi support. Most mainstream (1155/1150) Intel machines don't have that enabled, either in the mobo (only some Gigabyte, MSI and AsRock consumer boards have it enabled), or in the CPU (only non-k Intel CPUs on 1155/1150 have it enabled), most AMD machines have it enabled though, including your system, so if you want to, you can use all the functionality in fedora.

Gentoo is also enthusiast grade, but always requires advanced linux experience and knowledge, because there is no package manager, and you have to compile everything, which is not difficult, but it requires a thorough understanding of what's happening.