VFIO Pass through

Hey everyone hopefully someone is able to provide some help here or clear up what it is I’m currently missing. I am trying to set up VFIO pass through for my 1080ti for the VM and a 660ti to drive 2 separate monitors for a total of 3 which i use for work.

This is the guide i have been following but am unsure of how to resolve the issue i am currently having. When i black list the nouveau driver the are no longer running on the 660ti and there is no output on the monitors it is driving.

This is the guide i was following


Install the following packages
sudo apt install qemu-kvm libvirt-clients libvirt-daemon-system bridge-utils virt-manager ovmf
Setup GPU Passthrough (VFIO/IOMMU)

Ensure you are not using Nvidia drivers and blacklist Nouveau, Ubuntu’s built-in Open Source driver.

Create blacklist-nouveau.conf
sudo nano /etc/modprobe.d/blacklist-nouveau.conf

Include the following:

blacklist nouveau
options nouveau modeset=0

Edit GRUB entries
Open sudo nano /etc/default/grub and include intel_iommu=on
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_iommu=on"

Update your GRUB config
sudo update-grub

Determine your PCI ID's for your GPU
Run lspci -nn | grep -i nvidia

You’ll expect a return of something similar to this:

[email protected]:~$ lspci -nn | grep -i nvidia
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP104 [GeForce GTX 1080] [10de:1b80] (rev a1)
02:00.1 Audio device [0403]: NVIDIA Corporation GP104 High Definition Audio Controller [10de:10f0] (rev a1)

Note it down!

Add your kernel module for VFIO-PCI
sudo nano /etc/modprobe.d/vfio.conf
options vfio-pci ids=10de:1b80,10de:10f0

Add an entry to automatically load the module
sudo echo 'vfio-pci' > /etc/modules-load.d/vfio-pci.conf

Regenerate the kernel initramfs
sudo update-initramfs -u

Reboot your device!
If i change

blacklist nouveau
options nouveau modeset=0


blacklist nouveau
options nouveau modeset=1

all 3 monitors work is there something i can do about this or a better guide for me to follow?

1 Like

Lucky one. Or 660ti - the greate choice, i think.

Try using a softdep instead of a blacklist.

See syntax here:

You can not blacklist nouveau if you are using it for your desktop. Anyway this is the topic you will need to explore: procedure
You will need to assign the vfio driver to one of GPUs before the nVidia driver grabs it.