Return to Level1Techs.com

VFIO in 2019 -- Pop!_OS How-To (General Guide though) [DRAFT]

kvm
#42

Wait so fixed after copy paste? Or still error?

0 Likes

#43

sorry fixed it seems no more error message

1 Like

#44

well no more error but black screen on reboot lol must have messed up something gonna restart from the begining

0 Likes

#45

Might be the wrong card? Lol I made that mistake

0 Likes

#46

the 1st pcie slot can be listed after the 3rd ? gonna try and change the id number then ! because it would make sense for my screens where on just dark no error or stuff like that

0 Likes

#47

Could be. Mobo pcie layout is the dark arts

1 Like

#48

seems it was the issues I changed the id and as of now everything seems to be as it should kernel drivers are loaded. thanks Master of the Drak Arts lol

0 Likes

#49

Hi back again lol

So the passthrough works it’s the VM configuration that bugs me.
When I try to start the windowss install I land into a shell screen unless I confiigure the VM to launch with BIOS instead of UEFI but in this case the passthrough doesn’t work.

0 Likes

#50

are you booting your distro in legacy mode or did you properly install your ESP etc?

0 Likes

#51

you’re speaking of my host distro? or the guest?

0 Likes

#52

Wait are you using USB? Boot from USB is bugged by default in this setup. Need a newer ovmf. Do install from an actual windows iso file.

0 Likes

#53

sorry yeah, guest. If it’s older ovmf you need to use efi install media because it’ll get cranky about legacy.

0 Likes

#54

I’m using a windows iso file

0 Likes

#55

maybe I’ll just download a newer iso mine is like 4 month old

0 Likes

#56

I tried both when using BIOS I get to install windows but I can’t use the dedicated gpu when using UEFI the VM shows up on the screen connected to the gpu but I get the shell screen not hte windows install

0 Likes

#57

Make sure the iso is connected in the VM. You can type exit at the uefi and it might give you some more clues about what the VM is seeing.

In the GUI you might have to mark it bootable, connected at boot, etc

0 Likes

#58

ok I’ll try but i’m setting the vm with the gui virt-manager so isn’t the VM automaticaly connected to the VM? I’m using the KVM/QEMU user and the VM file is on the same nvme disk as my host because I haven’t figure out how to use a secondary ssd just yet I need to research that a little more I can use the ssd when using KVM/QEMUuser session but then I get an error about permission to acces the gpu and when I create the VM as KVM/QEMU I get the permission error about the drive but the gpu work. but I’ll figure that one out eventualy.

0 Likes

#59

thanks had to enable the VM to boot from the iso in the boot menu sorry for the bother

1 Like

#60

Hello there,
I’ve got the problem that the KVM seems to freak out after I shut down the VM.
It’ll only boot again after I restart the PC entirely (which sadly includes a hard-reset).
The displayed error is the following

Domain: internal error: Unknown PCI header type ‘127’

I guess it’s related to the GPU, but I’m not sure.

Even on the First boot the GPU does exactly nothing: Is there something I have to add/configure so that the VM will use my display(s)?

Hardware:
Nvidia RTX 2080
AMD Ryzen 2700X
Gigabyte X370 Gaming 5
32GB RAM

Thanks a lot in advance.

0 Likes

#61

This is most likely due to agesa 0.0.7.2

unfortunately a lot of manufacturers don’t let you downgrade the UEFI to fix it, but if you have a dual bios mobo there’s still hope. There’s an unofficial kernel patch floating around but it doesn’t work for everyone.

I’d suggest looking into doing a downgrade before trying the patch.

1 Like