Return to

VFIO GPU issues after rebooting Windows 10 guest

Hello all,

I have a Threadripper 2990WX on a MSI MEG X399 creation running Fedora 30. The box has a Radeon VII and a Radeon RX590. The 590 is bound to vfio-pci and this all works. I setup a Linux VM with the RX590 and everything works as expected once I set the PC type to i440FX. When I had it set to the Q35 chipset it would fail after a reboot.

Now I setup a Windows VM using the same settings but installing the AMD drivers on Windows crashes at 40%. When I change the chipset to Q35 the AMD drivers install.

Rebooting the Windows VM also works, and it comes back, but afterwards the GPU becomes unstable in 3D mode, most of the time it just doesn’t work. I have to reset host for it to become stable again.

I’ve tried to use the devcon64.exe trick from elsewhere on the forums but it doesn’t really seem to change anything.

Does anyone have any ideas? Thanks!

I have tried several other methods for trying to get Windows to work with the i440FX system type. So far no success. It appears that what happens with i440FX is that the AMD card gets passed through as a PCI device and not a PCIE device.

Apparently amdgpu doesn’t care about that, but Windows 10 really doesn’t like it. I wonder if it’d be possible to add a PCIE root in addition to the PCI root perhaps, and connect the vfio device to that root?

In case it helps, this is the GPU-Z information from the Windows 10 VM.screenshot

I also have an RX580 laying around. Is there any chance that’ll work better than a 590?

i had the same issue a while back with an RX590. i solved it by setting the CPU model to Core 2 Duo in virt-manager.

I was traveling so I didn’t have a chance to test your suggestion until now. It appears that setting the cpu to ‘core2duo’ didn’t really change anything.

Did you change any other settings by any chance?