Return to Level1Techs.com

Very slow Windows Performance in VM

#21

Do you mean this: options kvm.ignore_msrs=1 ? if yes, then yes.

i tried this: https://wiki.archlinux.org/index.php/PCI_passthrough_via_OVMF#CPU_pinning

0 Likes

#22

Isolcpus and cset are a different thing than pinning.

0 Likes

#23

Have you tried hugepages? Can you do uname -a to show your kernel version? What about errors in dmesg output?

0 Likes

#24

Ok. Can you say me how i do it?

Then i can try.

0 Likes

#25

Yes. I tried it. You can see it above in my specs. The usage of 20gb is from Hugepages (1gb size x 20). Dont changed anything.

Uname -a: Linux archlinux 5.1.2-arch1-1-ARCH #1 SMP PREEMPT Wed May 15 00:09:47 UTC 2019 x86_64 GNU/Linux

question beside: are you THE wendell? the original? :smile: if yes, then i have hope again!

0 Likes

#26

Yep. “The”

Ok. So. Hmm.

WAIT you have the rog zenith extreme. Ok so there is some funky Asus stuff there. Are you using any of the non default presets in UEFI?

Load optimized defaults, enable svm, iommu and set xmp and nothing else. Do Not use any of the oc presets.

Try that? I swear… if that’s it…

0 Likes

#27

Yes, rog zenith exreme. No i dont use any preset. I reset yesterday everything.

its everything default except:

XMP 1
multiplier to 40 for 4ghz overclock, vcore 1.38v (tried it without too)
SVM, iommu activated

Everything else is default.

I dont use any gpu passthrough at this time. I must first get the performance fixed.

0 Likes

#28

I am now 85% sure something on your motherboard is not actually set at default.

Load optimized default. Enable svm and iommu. Nothing else! Try that. Then reboot and enable only xmp. Nothing else.

With no GPU passthrough, are you using the correct accelerated driver on the host under x? E.g. Nvidia proprietary? Nouveau is going to be… not good for the spice bits.

Your performance issues could be combo of weird Asus behavior with any amd non stock settings plus a crap driver on the host.

0 Likes

#29

Interesting. Is there documentation of this issue anywhere?

0 Likes

#30

Not afaik but my experiences with Asus boards have been mixed for TR hence my reluctance to recommend them. I mention the issues in reviews but the oc stability has been less for me on Asus than anything. Even relatively weaksauce ocs.

0 Likes

#31

Good to know, thanks.

0 Likes

#32

Ok. i try again.

im in few minute back.

I dont use the nvidia gpus (i blacklisted every nvidia driver too). I want to passthrough this two cards into two different VMs:

(here i had a problem to passthrough the gpus because of the identical id. And the solution was so easy for my specific problem because i use 3 gpus. Simply blacklist the nvidia driver and it is to passthrough the nvidia cards without iommu or anything (i dont know why.)

I have three Cards built in like you can see. 2x ASUS Strix 1080ti’s and a AMD Radeon Pro wx3100.

I buyed the AMD card last week because of this problem: https://forum.manjaro.org/t/nvidia-gpus-zurzeit-unnutzbar-mit-linux/86236/2 (sry it is on german. im nativ german and dont speek english very well :slight_smile: )

Short translation: with nouveau or the proprietary driver was the overall performance great under linux (manjaro), until i resize a window, then it lags. And the only solution i found (from end 2018) was to disable something in kde/kwin for rendering resizing. Everything else (like games) runs super nice.

But it was not good enough for me. So i buyed the amd card and use the free, in kernel built-in driver. Its runs so smooth! Very happy with it.

But now, i try it again with the bios reset again.

0 Likes

#33

Ok, so host is using amdgpu and it’s accelerated properly? E.g. multiple videos, full screen videos, etc play without tearing? If so the symptoms here fit most perfectly with what I encountered from Asus on the rog z e late last year with @Dygear system I helped him build

You might also set pcie_aspm=off on your kernel boot line. I just checked my notes and that was necessary for me as well with a similar setup.

0 Likes

#34

So. i reset everything again. I install now windows 10 again in virt-manager like above described and report how it was after its finish.

yep. with zero problems. everything runs super fast and im able to play CS:GO for example and to watch a 4k video. like it should.

[[email protected] ~]$ sudo lsmod | grep amd
edac_mce_amd           32768  0
kvm_amd               106496  10
amdgpu               3952640  20
kvm                   741376  1 kvm_amd
chash                  16384  1 amdgpu
gpu_sched              36864  1 amdgpu
amd_iommu_v2           20480  1 amdgpu
ttm                   114688  1 amdgpu
drm_kms_helper        212992  1 amdgpu
drm                   495616  16 gpu_sched,drm_kms_helper,amdgpu,ttm
ccp                    98304  1 kvm_amd
i2c_algo_bit           16384  2 igb,amdgpu
gpio_amdpt             20480  0
pinctrl_amd            32768  0
[[email protected] ~]$ 

ok, i try it later (if necessary).

0 Likes

#35

Can you paste the output of dmesg also?

0 Likes

#36

Sure.

https://pastebin.com/3G7PypEc (i must post it as link, because of word limitation :slight_smile: )

0 Likes

#37

I dont get it…

Installation complete. in 11 minutes (last post i say i start new win10 installation). Completly! Everything runs so smooth like with virtualbox or vmware!

GREAT!

But why? only because of the overclock?

0 Likes

#38

I really spent a lot of time on it before I had to give dygear his motherboard. Pcie is negatively impacted even by xmp in some cases. The Asus presets in uefi wreck pcie performance tho. Sometimes. Even just nvme perf.

So glad it’s fixed. If you enable xmp only enable xmp but 2933 may be faster than 3200. I would not push past 3200 on 1st Gen TR.
2666 may actually be the sweet spot.

Only once memory speed is dialed in then you can fiddle with multiplier and voltage. 3.9ghz all core around 1.35-1.4v while not gimping speed.

0 Likes

#39

Do you speak about RAM Speed?

My RAM can only go 2666 because my mainboard is full of ram. All 8 Dimms are in with total of 64gb RAM DDR4 Dominator Platinum from Corsair. They have a 2800mhz profil in it, but once i set it to 2800mhz, the pc dont boot anymore and after a few tries it say the memory setting is faulty. In the manual from the mainboard i read somewhere that the mainboard support only 2666mhz if full stacked.

0 Likes

#40

Yes, ram speed. Ok, so what speed was xmp profile 1? 2666 is all you can hope for but make sure it is 1t timings.

Because you have so much memory you may only be able to achieve 3.7 or 3.8ghz before performance falloff.

2nd gen TR is much improved on this respect, but that motherboard struggles with ram timings. The 3 I have tried anyway…

0 Likes