Return to Level1Techs.com

User avatars are 404ing


#121

Without whitelisting the forums, there’s really not much you can do on here. I doubt that’s the problem.

Also, we don’t have any tracking cookies or scripts on here, aside from the built-in account activity, so you’re pretty safe in that regard.


#122

It maybe because of the tracker protection? Do you have it on?


#123

Just disabled it. No dice.


#124

Damn hmm thats strange. Mine disappears in firefox too but only for certain users but this comes because I use plugins like ghostery and decentraleyes and ABP


#125

It’s only users with default avatars.

It’s not about those plugins.


#126

Well thats good because I started inspecting source and wondered if analytics started analyzing avatars… ahah


#127

Nah, we’ve more or less tracked it down to the system-generated avatars.

If I switch back to the S, you’ll not be able to see it.


#128

Could be a data intregirty issue on the server end with how the gravatars are created


#129

See, that’s the thing. it’s not Gravatar. Discourse itself is doing this image generation.

I’d say someone fucked the generation method.

image


#130

There is no mystery here, I posted the fix the day it broke. They changed the URL for letter avatars and didn’t bother to setup a redirect, breaking every default Discourse install on the internet. Discourse only refreshes that URL when it’s restarted.

The fix is to either run ./launcher restart app or to disable external letter avatar caching and just generate them yourself. I suggest the latter, but either works.


#131

like Gerhard Schlager says on discourse forum:

Our previous letter avatar system would cache IP addresses for the CDN, this IP changed. We fixed the offending code and back ported to beta and stable.


#132

mine was also gone. Im not a frequent visitor of the forum, just every now and then. So when I ‘got back’ this week… it was really hard to find out how to get to my profile or see any reply notifications.

My avatar is 404 so im not seeing it in the menu either, not even that browser ’ img not found’ icon thing. Button works just fine tho, its just invisibile

image


#133

Yes. We know.


#134

So this only happens to me in firefox, I don’t get why all other browsers are fine. Posting this reply via chrome.


#135

It’s a 404 on the server side. Your browser doesn’t matter. Either the URL exists or it doesn’t.

Dunsparrow:~ root# curl https://forum.level1techs.com/letter_avatar_proxy/v2/letter/l/76d3ee/135.png

<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>
<hr><center>nginx</center>
</body>
</html>

#136

I understand that it is server side, why does it work in opera and chrome and brave but not firefox?


#137

I cannot think of any explanation short of magic.


#138

Well this testing I have done was not proper. I am running Chrome behind a vpn, and when I looked at firefox it wasn’t behind the vpn. But now firefox works too (while behind vpn). I don’t know though.


#139

I just tested in Chrome and Opera and it’s still happening. Perhaps you’ve cached the images?


#140

Nope, I did a clean install of windows a day ago and logged in for the first time today on the fresh install.