Return to Level1Techs.com

User avatars are 404ing


#21

@Goalkeeper what did you do!

image


I see this when I try to @ users:

image

I’m on FF 65.0 atm.


#22

Under profile picture, I selected " System assigned profile picture". I think a lot of other people did too. That is why there are people who are also naked. Looks like there is something wrong with the part of the system that is responsible for that function on certain browsers… Or something.


#23

I had the same problem while browsing forums at work today. Though the avatars were not broken, there just simply wasn’t anything. Noticed this when I browsed front bage and some new threads didn’t have any avatars visible. :thinking:

I was using Chrome at work. I thought the company firewall was playing tricks on me rather than forum having a problem.

Also, this is creepy: :cold_sweat:

image


#24

Wasn’t able to reproduce this initially, but I did see it on the “Useful Guides” topic that @alwaysFlOoReD posted (thanks for the screenshot!).

I’m looking into it now, but afaik nothing has changed on the forum recently that would cause this. It is definitely related to using the default Discourse icon though.


#25

nginx config issue, perhaps?

All of the broken ones seem to be using the letter_avatar_proxy/v2/letter path. User-set profile images work fine.


#26

Doesn’t like Goalkeeper at all. Firefox on mobile, but have seen it throughout the day on FF in windows and Brave on Fedora 29. :slight_smile:



#27

Happening to me on Chrome in Windows. I’m not unconvinced @Goalkeeper isn’t trolling us all.


#28

Now you’ve been deleted too. Take that spammer.


#29

Test.

Edit: Hmmm. I have an avi while posting now. But not in the top right of the page


#30

The letter avatars are served by nginx inside the container, basically the admins need to run

./launcher rebuild app

and that will almost certainly fix it. Also check that it’s set to

/letter_avatar_proxy/v2/letter/{first_letter}/{color}/{size}.png

in admin settings.


#31

ur a wizard image


#32

That was my thought, too.

This doesn’t explain why it seems to work with Chromium, but returns a 404 with Firefox. That’s baffling me. User agent should not determine server response…


#33

The plot thickens.


#34

Has anyone tried clearing their cache?


#35

Yes, no difference


#36

I get 404s in both Fx and Chrome.


#37

Nothing wrong on my end. Could it be dns related?


#38

1.1.1.1 here


#39

Not seeing it on Opera.


#40

Sure, if they point to a CDN rather than the local web host.