Return to

'USB Over Current Detected' on ASUS Prime-B350 Plus (solved)

I have an ASUS Prime B350-Plus motherboard. Some time ago I got an error message which said ‘USB Device Over Current Detected’, which prevented the motherboard from booting or getting into the BIOS. I RMA’d that board, and the replacement board had also started showing the same error after a few boots. I powered the motherboard on after weeks and managed to get the machine working today, and updated the BIOS. However, it seems like I am intermittently getting the same message again. What could possibly be the issue?

I was earlier running Ubuntu 19.04, and switched over to Pop!OS 19.04 this morning, in case it is relevant.

Well, what USB devices are you using?

Also, welcome to the forum!

As of now I only have a Logitech K840 keyboard and a G102 mouse plugged in. I have used both these devices with my laptop recently, so I didn’t think they would be the issue.

Also, thanks!

Could get a cheap USB current meter and check

Try unplugging any internal (e.g. front panel) USB cables. If one is causing a short somehow it could be the cause.

Also remove the motherboard from the case if possible to make sure nothing in the case is shorting to the motherboard.


I had followed these troubleshooting steps when it first happened. None of them helped. The board has started throwing up the same issues again.

I checked which ports aren’t working, and the ones that are causing the issue have nothing plugged into them

In case someone else is having the same issue, in this instance the problem was resolved by replacing the PSU. One of the 5V rails was having issues.

1 Like