Return to Level1Techs.com

USB 3 HDD won't mount w/o format; Nvidia Shield TV

My shield kept prompting me to delete files because storage space was low, even though I had more than 500GB free on my USB 3 HDD mounted as internal storage. So in an act of desperation I reset the Shield. Now when I connect the USB 3 HDD (WD Passbook) The Shield wants to format it no matter which option (mount as internal or removable USB) I choose. The problem is I have 2TB of music, movies and pictures stored on this HDD, some of which only exists on this drive. I tried connecting it to a my PC but lo and behold Windows wants to format it as well (though I’ve not tried any command prompt tricks as of yet). Any suggestions?

I don’t see any way for you to retrieve your files.

The whole idea of formatting media as “internal storage” on Android is to add storage capacity that is treated the same as internal storage, while also retaining the security of internal memory. To accomplish this, the media is formatted specially, and encrypted using a key known only to the system it was formatted on. Once you reset the system, that key is lost.

Ideally, you’d only format media as internal storage for installing apps on low capacity devices. If used for personal files, they should always be backed up off-device, since in case of host device failure, all the data on the external media will be unreadable.

For media use, normal formatting should be used to facilitate easy file transfer to and from other systems. (Unless security is desired.)

2 Likes

the data on the HDD is lost to time itself. There is no real way to retrieve the data back off of it. If your shield is rooted then you can try and pull the encryption key out of the device but that takes time, hardware, and praying to the right gods.

http://www.forensicswiki.org/wiki/How_To_Decrypt_Android_Full_Disk_Encryption#Locating_the_Encryption_Key

https://source.android.com/security/encryption/

https://source.android.com/security/encryption/full-disk

1 Like