USB 3.0 HDD Connecting and Disconnecting

Hey Guys, 

So i just received a WD 1TB Passport drive to try to do backups of my laptop. The laptop i have in an Alienware M17x R4 running Windows 7 x64 bit. The computer has 4 USB 3.0 Super speed ports and 1 USB 2.0 port that doubles as an e-sata port. So I formatted the drive to NTFS, and stated a file transfer to test it out. I was getting about 140-160 Mb/s using the USB 3.0 ports. The thing is, after about 45 seconds of file transfer i hear the internal drives of the laptop either stop or start spinning and all of a sudden the external HDD disconnects and reconnects. this is really annoying because I can't transfer large files without the connecting messing up. I tried unplugging all other usb devices, setting the usb suspend power option to disabled, and updated the usb 3.0 drivers and the hdd firmware to no avail. 

This is the interesting bit. I plugged it into a USB 2.0 port, and the hdd worked fine, but only at usb 2.0 speeds. I've tried other computers, and the 2.0 ports work fine while the 3.0 ports keep giving me the connect/disconnect errors. I've looked on various other forums and have found others that are dealing with the same issues, but no one has actually found a solution that's worked consistently.

Any help would be appreciated. Thanks in advance.

Does the passport drive require external power?

nope. It uses a WD proprietary plug to usb 3.0

Go into your laptop's bios and enable everything USB 3.0.  Don't leave it to auto.  i will edit this post in a little I am researching this.  It does seem like a common problem.

*make sure your chipset drivers for your laptops mobo are the latest.

*when you updated drivers did you go to Dell's website or Intels?  If not Intels I would download the latest there.

Yeah, i've enables all the USB 3.0 stuff in bios and updated drivers from intel's website.... I'm still getting the cyclical connect/disconnect

I had this problem i will try to find the driver that fixed it for me.

Edit: This might be the one.