Return to Level1Techs.com

[Urgent]Windows into a VM and installing Manjaro

console.log(“Hello world”);

I’m trying to setup a pretty safe system for myself, like the one from someordinarygamers.

I’m wondering if I can move my existing working windows 10 instalation and make it into a VM.

I’m going to get a M.2 SSD intel p660 to get enough space for the windows (100gb) to operate and have a 50gb partition for Linux. Also the rest is for workstation stuff. Like the other HDDs that are connected to the pc.

I’m probably going to have some spoofing software on the linux side to be pretty untraceable and then have my server as a vpn.

console.log(“Thank you in advance”);

just dd the entire device windows is on into a file.
then use that file as a virtio storage device on the “raw” format setting.

might have to manually add the premade windows boot loader to OVMF’s boot options.

Windows may or may not behave itself after such a dramatic change in “hardware”.

Hey thanks.
Can you dumb down the comment a little so I can try to do that.

just a stupid sys admin here.

use the utility “dd” to copy the contents of the entire storage device containing Windows to a file.

if the windows device is /dev/sdc, and i want the image to be in my user’s home directory i would issue
dd if=/dev/sdc of=/home/mathew2214/WindowsHDDCopy.img

then, in virt manager, hit “add hardware”, “storage”, “select or create custom storage”, click “manage” to browse to the file we just created. set bus type to “virtio”, if prompted for a format select “raw”.

then, boot your VM and hope OVMF can find Windows’ EFI file. if not, you’ll have to add it to OVMF. or use an image of a GRUB2 disc to boot windows.

alternatively, you can just passthough a storage controller and physically connect it to the device containing Windows.

1 Like

While matthew’s answer is really good I’d like to add my 2 cents and recommend using vmware over KVM/virt-manager since the directory sharing, clipboard sync and video output are working better on vmware with windows. For linux guests kvm is my personal go to.
(also, vmware and kvm can work on the same host at the same time)

Isnt vmware a paid service? Ive used virtualbox and i have recently been able to shift towards virtman and qemu. Is VMware able to use stuff (like files) from virtman?

I thought having the windows on one of the partitions of the m.2 if that is possible. I could just copy my windows on it.

I have no idea, I thing Mutahar on his channel, mentioned above, used virtman or something on archlinux. I guess the harder part is to have an automatic mac and ip changer.

And, yes I’ll have the third partition and the 3 other hard drives as shared storage.

It is, but workstation player licensing is free for personal use

https://www.vmware.com/pl/products/player/faqs.html

**Can I still use VMware Workstation Player for free?**

VMware Workstation Player is free for personal non-commercial use
(business and non profit use is considered commercial use).

VMware player is free. VMware workstation is not.

Player is “free” as in can use, but not GNU level free as well which is a problem for some. I’ve used most major VM software down to even their ESXI. It’s great software, I won’t deny, but there’s little that it has to warrant the extra headache and/or money unless they have a feature that you really want. That said, if you want that feature, it’s fantastic, and I won’t fault their software on that.

If you had the window installation on a separate physical drive you can pass the entire HDD through to the VM instead.

Switching back and forth from bare metal to VM just results in win10 configuring devices before sign in for a few seconds. This is specifically with win10 pro as I have not tried any other version.

1 Like

I just wanted to say that I that I only have windows systems currently available so. How do I copy now the files onto the SSD? (I currently have windows 10 on a 128gb ssd and wanting to move it to the 100gb partition)

I would keep Windows on the SSD. Install Linux on your new M.2 drive. Then pass-through the whole Windows drive to your VM like @Windforce suggested. Great performance, and easy to switch between VM and “bare metal”

Well I already started. Got to 68% then it stuck.

I’ll just install the manjaro and pray to god then.

Ran into “Error: out of memory” in 3 seconds on starting the pc. wtf, it has 16gb dram, 8gb vram, atleast 3 terabytes of hard drive storage…

And I only have one m.2 slot so installing linux on the other m.2 does not make any sense…

edit: tried rosaimagewriter and it errored. Then re-ran balena etcher, now it works.

edit: “Installation failed: Boost.Python error in job bootloader command grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force returned non-zero exit status 1”

I want to say here that this is why I hate linux… It just never works when I want it to.

edit: Trying now to re-create the partitions in the installer but cannot click continue…

edit: now can’t get more than 4 partitions for boot and boot/efi

edit: converting to GPT, adding the ext4 30GB for manjaro with / flag, 100GB NTFS for windows, 350GB NTFS, 150MB FAT32 with flag /boot/efi, 150MB FAT32 with flag /boot
But yet it warns me that /boot is non existant

edit: changed the language to something I actually understand and now I have GPT drive with: 97.7GB NTFS, 29.3GB ext4 /, 347.7GB NTFS, 1.3GB FAT32 /boot, 1.0003GB FAT32 /boot/efi with /boot flag.

I hope that is right and I’ll just proceed because it does not give any errors…

Edit: I’ve tried to follow someordinarygamers video:
https://www.youtube.com/watch?v=h7SG7ccjn-g I came to 15:40 about and I have too many on the list, no idea how to proceed. I don’t even know if I have to do this… But I will now revert my windows changes so I’l move the 68% back to the ssd and just use that for now, until the path is clearer.

I am not familiar with manjaro and its installer but seems like you got past that issue.
You are looking for the GPU you want to pass through to the VM on the IOMMU listing. What you would like to see is the GPU in a group by itself, which would contain two entries, one for the video and another for the sound. If not you are going to have to use something called the ACS patch and hope it works. You can also look at a BIOS update if you run into these issues as this may have fixed the groupings.

Hey,
There were tens of lists with amd something.

I also have a GT 720 installed in the pc but for some reason it does not recognize it neither windows… And having amd cpu and gpu is … not cool when you have the list…