Return to Level1Techs.com

Upgrading to Debian 10 gone wrong

Few weeks ago I upgraded from Debian 9 to 10 (buster). It went smooth for the most part. Some packages needed to be reinstalled, but all in all things are functional. The only thing that is bugging me menu crashes or the “right click of death” issue. In short, GTK applications crash if you attempt to bring up a menu by any means. You could be using right click to bring context menu or go to the top bar, it always crashes instantly. It affects multiple applications such as gedit, desktop, nautilus, etc. It doesn’t seem to be graphical environment specific as the same thing happens if I login into GNOME desktop or Cinnamon.

I’ve tried:
-reinstalling nvidia drivers
-explicitly disabling wayland
-running said applications in debug mode (no error messages were produced)
-reinstall cinnamon

dmesg produces this record

[542499.927191] nemo[11846]: segfault at 1 ip 0000000000000001 sp 00007ffdf59b7de8 error 14 in nemo[56001eb23000+2d000]
[542499.927195] Code: Bad RIP value.

Running gedit using fish

fish: “gedit” terminated by signal SIGSEGV (Address boundary error)

Running gedit using bash

Segmentation fault

Could someone guide me through troubleshooting this issue? Let me know which configs/logs are needed.

With the fact that your applications aren’t opening, and gedit returns a segementation fault, I can only assume that the memory address of some programs might have been screwed up in the update process.

There’s no need to worry as this is a common issue, and has actually happened to me two or three times in the past.

You have a couple options:

  1. You can either purge the applications giving you trouble (gedit, Cinnamon, anything gtk related, etc…) and remove associated program files (this is equally as important)

Or:

  1. Reinstall the OS. I know it sucks to think about but it is what it is in the end. Seg faults are absolutely awful if they happen on a mass scale as seen here…

For the future I would HIGHLY suggest using BTRFS on your root partition and enabling snapshots. It’s come a long way in terms of stability, and is even getting more common among data centers. It will save you so much time and hassle if configured properly.

Unfortunately, that’s all I can really recommend on the matter. I hope you get this sorted out, and wish you the best in doing so

Actually, come to think of it, each time I’ve had this happen it was while running Cinnamon. Given that I have used it primarily since switching from KDE that isn’t saying much though.

Just a thought

To be exact, the only application that doesn’t open is Nautilus. Everything else starts up but crashes if a menu is being called.

Just tried purging gedit, no change. It would be great to find the way to troubleshoot this. It is a minor annoyance at the moment and I’m willing to spend time looking for it.

1 Like

walk us through how you did the upgrade. Are you running any 3rd party repos?

I am a Debian SID user.

2 Likes

Gladly!

I’ve used this guide to do the upgrade.

Here is my source list:

# deb cdrom:[Debian GNU/Linux 9.1.0 Stretch - Official amd64 NETINST 20170722-11:28]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.1.0 Stretch - Official amd64 NETINST 20170722-11:28]/ stretch main

deb http://ftp.ca.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.ca.debian.org/debian/ buster main contrib non-free

deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# buster-updates, previously known as ‘volatile’
deb http://ftp.ca.debian.org/debian/ buster-updates main contrib non-free
deb-src http://ftp.ca.debian.org/debian/ buster-updates main contrib non-free

# Jessie list
# deb http://ftp.de.debian.org/debian jessie main contrib non-free
deb http://security.debian.org/ buster/updates contrib main non-free

So that guide was pretty straight forward which was nice.

Did you have any issues when you did the upgrade, like any held back packages? You mentioned that you had to manually some packages. did you use the debian packages or Ubuntu packages to do so?

In general it sounds like you may have some conflicting packages installed. Like maybe some 32-bit packages mixed with 64-bit packages maybe.

I recommend performing an apt clean && apt update && apt upgrade. Reboot and then if the behavior is still there, then an apt full-upgrade.

No packages came up during pre-flight checks from the guide, If that’s what you are asking. There was a list of packages that failed to install during the upgrade. I ran the apt full-upgrade once more and those seemed to not show up anymore. However, after I did the first reboot things like nvidia drivers or cinnamon were not present. I did everything from Debian repos.

Very possible. Perhaps some of the Debian 9 packages were held back, but I’m just guessing.

Just did that, it produced no result. “Nothing to upgrade” it says.

I’ve pulled a list of packages marked as “not-installed” from dpkg log. This might be helpful.

not-installed.txt (56.4 KB)

Okay,

It looks like you are running AMD64 as I see not :ix86 packages in that list. I cannot remember the command right now to see if multi-arch is enabled, I am at work. But your apt list did not show any multi-arch inclination.

If some failed to install, then a dist-upgrade was probably not the best idea. When packages fail, apt usually will not let you continue until you resolve the broken packages.

coud you try an apt -f install The -f means fix. If there are broken items then it will take care of it. You also may do well to reinstall the gnome and cinnamon meta packages. this can be done using the previous command or if you want to be 1337 h4x0r, learn to use dpkg. Example dpkg-reconfigure gnome3. This will do a reinstall of the locally cached version and will let you reconfigure any options that may have been silently installed or skipped during your dist-upgrade.

Outside of that, I would suggest a reinstall of Debian or a jump to the testing branch to see if the issue goes away. Again I run unstable and I am not getting the issues that you are. Something definitely went wrong during your install. If could be that Cinnamon and Gnome3 package requirements may have diverged as one is a fork of the other.

1 Like

Thank you for your response. I jumped to Manjaro)

I hope that works out for you. I use ArchLinux as well so, I may be able to help if you have issues with Manjaro.

1 Like