Upgrade from 1800x to 3700x on aorus ax370 gaming 5 wont post

Soooo tonight I got myself a super dope 3700x to upgrade my pc from a 1800x (ax370 gaming 5 board on bios f40 + gtx950 + Rx580 + 4x8gb of team group ram) but the thing is that even tho my bios should support my cpu, the board does not post, the post code stay stuck on 00 but all fan and rgb goes crazy, tried to reset cmos with no luck.

Anyone knows something I might not?

1 Like

Dual GPU? From different manufacturers (AMD and NVidia)? Try removing one of them (would suggest removing the GTX950).

1 Like

Did you upgrade both bios’s it’s a dual bios board, also take out one GPU and if it boots do the following

Disable csm, enable above 4G decoding it could have reset above 4G decoding and csm settings and the board might not have a enough bar space without those settings


I realized that the second bios wasn’t updated, so I swapped my cpu back, did the upgrade on the second bios f4 → f31 → f40 this did not solve my issue tho.

For my dual gpu I tried just with one (tried with both) with no success.

I did try to go in disable csm and enable 4G decoding with the old cpu but with no more luck when swapping back.

I tried then to upgrade my main bios to f42 using the old cpu but still no luck.

Saw people saying it could be issue with 4 ram or something so I popped out 2 of the 4 stick but I am still getting the same result.

The reason I am trying to not just flash the latest bios but a confirmed supported one is that when I upgraded to f50 before getting my 3700x I realized that this bios version break my IOMMU group making gpu passthrough almost impossible.

I also saw that near the debug lcd of the mother board there was debut led, when the 3700x is in the cpu led is on

1 Like

If I remember correctly you still had auto/enable/disable bios options for IOMMU on the latest bios update, I had a 3800XT in it

Could you link me to who said it was broken


I did, by broken I don’t mean that there are no IOMMU but that suddenly just to mess around with us both gpu are suddenly in the same IOMMU in the latest bios

Since my last post, I downgraded to f31 again, found a ssd with win10 ran ecfw updater then reflashed f40 and still no luck

1 Like

Have a friend with an am4 board? Beginning to suspect it’s the CPU.

1 Like

I could try on a asus b450 prime but I’ll need to update that bios too

I see why you are suspecting the cpu, my only concern is that it’s a brand new fresh out of the box cpu so it would really be weird to have it doa

1 Like

Do you have your CPU power cable plugged into the board from the PSU? Top left of the motherboard; should be an 8-pin connector. Also, what are the odds your PSU is bad?

The cpu was properly plugged the odd of the psu being bad is next to none

What I ended up doing was head to a computer store and ask them to test my 3700x luckily enough the cpu was not dead, so then since I already wasted to much time and frustration on the pc that I left my whole build for them to make it work, should be good this afternoon hopefully.

Ill try to ask them what I missed in my install for future google reference for anyone going through this hell.

The reason I asked is because I found this thread: Error code 00 on AX370 Gaming K7 | GIGABYTE USA Forum

Wasn’t sure what the rules are about posting links, so was just working through the thread on that forum, without posting the link, but I’ll just take the chance.

No gore no porn be respectful no shaming bashing etc other users in posted media otherwise meh

Don’t like post bongs and guns obv.

You don’t happen to be using displayport would you

I actually was using displayport :eyes: so that could be somthing to look into

For now I still havent had my system back since the store is closed on sunday but I should be able to pick it up tommorow, I have no idea if it worked or not since it was supposed to be done by the morning but it took more time than expected when I checked up yesterday and then did not got any news so idk what’s up there but I’ll be updating possibly with the solution tommorow.

Update, even the store where I brought my pc abandonned the project so im not sure whats up with this board so I changed the board cause I wanted my pc back and quickly and upgraded.

Sorry everyone not really the answer we were looking for but look like just some motherboard even if they claim they can get 3rd gen ryzen with bios update will have some particular issues

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.