[Update] 25GbE asymmetrical Win 10 Pro performance - Intel XXV710

Hi,

After 3 days of testing TrueNAS Core / Scale and noticing slow network performance, we were ultimately able to determine that under Win 10 Pro & Win 10 Pro Workstations we have ~23GbE outbound but only ~6GbE inbound.

Switching across a QNAP QSW-M5216-1T

Intel XXV710-DA2 NICs on both ends - client Win 10 and server (both BSD and Debian). The issue was not present when we tested with Ubuntu on the client - USB boot. Testing was done with iperf and CrystalDiskMark - same results.

Have others run into this issue? Worked with @felixthecat on the testing.

TIA

1 Like

Any increase in throughput when running multiple iperf threads (-T parameter)? And what is your NIC’s receive buffer set to? Can you try bumping it up to 2048 if you haven’t already?

Tried Win 11 Pro as client - got iperf symmetric. Ok, should result in better transfer performance? Nope. Puzzling.

Tried buffer at 2048 - no difference.

Update:

Syncing the MTU between the Windows Client, Switch and TrueNAS Scale Server at 9000 yielded Read Performance of around 12Gbit/s via Samba.

This is still slower than Write Speeds, but a significant improvement.

Encountered was one major pitfall:

Setting the MTU in the Adapter Settings under Windows to 9000 yielded worse Performance and Packet Loss.

When checking via Power Shell, it turned out that Windows would set the MTU to 8086 (minus the Ethernet Header?) when 9000 was entered via the GUI.

After adjusting the MTU manually to match up with Switch and TrueNAS/Debian, Performance increased to the 12Gbit/s Read mentioned above.

1 Like

Awesome job @felixthecat - appreciate you sticking with the problem and finding the solution. Network is rocking along now… can’t thank you enough!

1 Like

Should be noted - Windows 11 Pro Workstations in this instance. Likely the same under Win 10 Pro; but ya never know with Windooozzzeeeeeeeee…

1 Like