Unraid Remote NAS access


I’m having an issue with remote access to my unraid server. I have tried both wireguard and Tailscale, but perhaps im doing something wrong.

My goal is to be able to securely access my unraid server from a location off of my home network and have it appear under network devices on Mac/windows, so that I can pull audio and image files from it for video projects.

any advice?

Have you tried ZeroTier?

1 Like

Given what you are trying to do, tailscale is probably the easier choice as compared to straight wireguard.

When you have tailscale up and connected on both the server and the device outside your network, can you ping the tailscale IP address?

Have you got any required ports open on your router that forward outside traffic on that port to that specific device (unraid box)?

I have wireguard setup on my router and it requires the correct port to be forwarded to the device (in my case the router), otherwise i see and connect to nothing.

I have not tried ZeroTier yet.

on the windows machine outside my home network when I try and ping the TailScale IP the 4 packets it tried to send all failed.

on my Mac laptop outside my home network it will Ping the IP but won’t show as a network device

I followed a WireGuard tutorial and forwarded ports as needed. when I do, I can connect to the unraid GUI in a browser but not see my server on that network

If you can access the GUI via a browser outside the home network on that machine your most of the way there…

What are you using to try and access the files?

Typically, I have had to sign in to a user account to access the SMB share… have you got a user (preferrably not root) which has access to those shares?

Also, sometimes i find I have to use //IP.ADDRESS of the server in windows explorer when its being picky about hostname

My goal is to be able to access the files via either Finder on Mac or the file explorer on windows. I do have an additional user setup already

So in that case, there is something wrong with the tailscale setup, presumably on your windows machine. I’d probably check with their help documentation and then their support.

Have you tried to mount the folder manually with the IP. I don’t have macos so I don’t know the exact process for it, but it should be possible. That will let you know if it is a discovery issue or something else.

it looks like at least on MacOS Tailscale is now working to connect to the server. still need to do more testing on the windows connection