Unknown Device After Installing Drivers

So after installing all of the latest drivers from the manufacturer’s website, I still have an “Unknown Device” in Device Manager. I was wondering if anyone could help me with this. I’m already in contact with Asus about this, but so far… yeah… not going to well with their support…


Got some really weird fucking results. All I did was run the “Setup.exe” file on the CD that comes with the motherboard, and that took care of the issue. I kid you not, I didn’t even install any drivers, all I did was double click the “Setup.exe” file on the CD, and refreshed Device Manager, and it disappeared.

What the fuck.

Someone tell Linus Tech to stop telling people to throw out the motherboard CDs. Jesus.

Probably nothing important anyway as it seems. :slight_smile:

I highly disagree.

There useless junk.

Why do you assume its your motherboard when you have other devices connected?

They’re obviously not, if it just solved the problem.

If I were to remove all other devices, I would get the exact same working solution. I don’t understand the point of the question.

This says you say its a motherboard problem

This says you have a printer installed. So obviously we cant say its the motherboard when you could have any number of devices connected. So we cant help.

You’re CDs are also useless because you still have to update your drivers to the latest, if it fixed it its because you missed a driver on the download page.

I already downloaded and installed all of the latest drivers from the manufacturer’s website. I didn’t miss any drivers.