Unable to boot into windows

This story begins in the beginning of the day when I decided to update windows.
Windows updates, and everything is fine.
I then open up MSI afterburner to do a bit of overclocking.
This happens:

I reboot.
Overlock a little bit more, video drivers crash, then reboot again.
This then happens: http://imgur.com/7SIacrM
I clear the CMOS. DIdnt fix it. Decided to install ubuntu and delete Afterburner to see if that was the issue. Doesnt work.
Lounge gives me this video to help:

Nothing has worked.
Any help is appreciated.

Edit: control alt delete reboots the pc

what about ctrl+shift+Esc
does that bring up task manager?
I'm guessing you're on windows 7?

ctrl+shift+Esc does nothing
on windows 7

try most recent restore point and the next one after that?
check RAM with http://www.memtest.org/
check hard drive with http://www.hdat2.com/ and or your HDD manufactures diagnostic software if they have any.
check the SMART attributes, your hard drive might just be getting sick.
both those diags are on the hiren's boot CD if you want an easy boot medium that has them all on it.

Problem with the restore points, is that something along the lines of what happened today removed all of them. Nor can I boot into recovery.
Also its a SSD, not HDD if that makes any difference.

If you can't boot to recovery console you can boot to a windows CD/USB to get there. How do you know your restore points are gone if you can't get into recovery console?

I did boot into recovery with a usb. I no longer have that usb becuase it was made into a ubuntu usb.
IM remaking it now though.

Nothing in recovery mode has worked.


in command prompt in recovery console
bootrec /ScanOs
bootrec /rebuildbcd
bootrec /FixBoot
bootrec /FixMbr

if no change or scan os say's it can't find any installations

ren c:\bootmgr bootmgrbackup
bootrec /RebuildBcd
bootrec /FixBoot

failing that
bcdedit /export C:\BCDBackup
in c: type "cd boot"
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec /RebuildBcd

All failed. When I tried the last one I got this as an error:
The store export operation has failed.
The system cannot find the file specified.

did you run chkdsk /r on your drive, might want to start considering backup up your data if you don't already have a backup and doing a reload.