UEFI Virgin

Hey guys, I've tried many times to install an OS via UEFI method on many different machines but I always encounter a problem, (never the same one twice) can't complete the install and have to use the legacy BIOS to get the job done.

I use RMPrepUSB with Easy2Boot on a 128GB flash drive with multiple OS images on the flash drive. I have followed all the tutorials I can find and even have Clover on the drive which should allow me to do a UEFI install but alas I'm still a UEFI virgin.

Could you guy's do a tutorial on a bullet proof UEFI install or some of the common issues with UEFI installations (Such as USB needing a driver to complete and install) and their solutions.


Keep up the great work!



What OS are you trying to install?

Your issues may be from secureboot which will block any unsigned operating systems from booting. 

So far I've tried W7, W8 and W8.1. I've made sure secure boot is turned off in the BIOS for every install I've tried.

That's really odd. UEFI is pretty much a Microsoft ploy to make it difficult to install an alternative operating systems, such as Linux, and the one thing they have right is a easy installations. Are you trying to setup a dual boot with another OS?

I've done nothing but a straight OS install on a clean disk, nothing fancy, just the windows default partitions created during install. The furthest I've gotten is windows will begin to UEFI install then hang and ask for a USB driver disk to be inserted to complete install. All the others I couldn't even get the windows UEFI install to start. It would just load forever.