Ubuntu won't shutdown or suspend

So I just started using Ubuntu 13.04 on my laptop (a Dell). Everything works fine, and everything has been going great except that I cannot shutdown or suspend. When I try to suspend, the screen and hard drive turn off, but the power button light doesn't go into stand by. Also when I try to shutdown it gets stuck on a screen that says:


speech-dispatcher disabled; edit /etc/default/speech-dispatcher

Does anyone know how to fix this?

Thanks in advance.

It's actually very easy to fix: keep the power switch pressed in until it forcibly shuts down, briefly take out the battery and put it in again, start it up with a non-Ubuntu GNU/Linux distro of your choice, like Mint on Debian, Manjaro, Fedora, OpenSuSE, etc..., click the install button, and in the screen that follow, choose "use entire volume", or "replace currently installed operating system", wait a few minutes, reboot from HDD, enjoy a troublefree experience...;-)

have your tried to open terminal and type in

---"sudo poweroff"

then put your password in at the prompt

you could also try this http://askubuntu.com/questions/66723/how-do-i-modify-the-power-options

"Default buttons behavior

Install dconf-tools:

sudo apt-get install dconf-tools 

Press alt+f2 and open dconf-editor (or in a terminal type dconf-editor)

Navigate to org.gnome.settings-daemon.plugins.power and set your default button-power action there:"


I looked at the link that you provided, and it appears to be working now. It was very helpful.

I also have one more issue. Upon booting up, before the ubuntu splash screen, I get this:

usb 1-1.4: device descriptor read/64, error -32

usb 1-1.4: device not accepting address 9, error -32

hub 1-1:1.0: unable to enumerate USB device on port

I assumed that this meant that my USBs would not work, but they all work (with mouse and removeable storage. So, I don't know what that means, or if I should try and fix that.

well your usb works and you can now shut down your pc. I wouldn't worry about it. this is what i found http://www.geekdevs.com/2010/04/solved-unable-to-enumerate-usb-device-disabling-ehci_hcd/