Return to Level1Techs.com

Ubuntu Wayland issues

So, I’ve been having issues with Wayland on Ubuntu Groovy since about mid-December 2020. After some update was installed, most graphical applications suddenly stopped opening in the Wayland session of GNOME. GNOME applications, like GNOME Calendar and GNOME Clocks, open just fine, I can even use the terminal without any issues, but trying to open Firefox, Thunderbird, and so on simply leads to them seemingly running running in the background, but never appearing on screen. No matter for how long they remain like that, they will not terminate on their own with some sort of error. There are also no warnings to be found of any kind in journalctl, much less errors. I’ve tried to figure out what could be the issue, but I’m thoroughly stumped, as it doesn’t matter whether the applications are running natively on Wayland or are running on XWayland. The only thing that matters is that they are not GNOME applications. Hell, even extensions fail to run! Ubuntu Dock runs, but Weather and the like don’t. Well… the others don’t, but Weather just looks broken, like it’s perpetually trying to load weather data and failing. Everything works fine in the X11 session for me and one of my friends who also has Ubuntu Groovy reports no issues with the Wayland session on his laptop.

I was hoping that some later update would come to save the day soon enough, but here we are…

What graphics card?

There are no graphical issues to be found. The GNOME applications open with no issues and the rest just kind of… stall, I guess? I forgot to mention this earlier, but no output is given even when they are run from the terminal.

This is my laptop (i5). I’m using the Oibaf Mesa PPA and I’ve removed the script that comes with nvidia-prime which disables Wayland when the profile is anything other than Intel (I mostly use the dGPU for CUDA in Blender, so I don’t need to be running in the X11 session). Of course, there are no issues with NVIDIA OpenGL and Vulkan when running in the X11 session.

I’ve gone through many different kernel versions, including the official ones, but no dice. I doubt that this would have stuck around for this long if it were somehow related to some Mesa bug from master.

Maybe I am being dense, but what I was alluding to was the fact that EGLStreams is still very experimental. Anything running in X or XWayland would be fine if using the dGPU. Anything running in native Wayland and using the nVidia GPU could cause issues for you. You also cannot mix Wayland and XWayland sessions with the EGLStreams extension right now, unless that has been fixed in the last 3 months.

**Disclaimer
I don’t use nVidia products and I only have superficial knowledge about their Wayland support. I know that it is buggy and nVidia are not maintaining the implementation. Each DE group is implementing EGLStreams based on the nVidia spec with no real support from nVidia. So your mileage may vary.

  1. GNOME, at least the official Ubuntu build, doesn’t support EGLStreams, so even the performance (dGPU-only) profile ends up using the iGPU for anything that is not CUDA.
  2. Only XWayland applications would be broken if it were an EGLStreams issue as far as I’ve heard.
  3. I tried logging into the Wayland session with the profile being set to Intel (no NVIDIA drivers loaded), but it was exactly the same.

Side note
I’m not sure how related this is, but GDM stopped responding during shutdown at the same time when this started happening, leading to every shutdown being one and a half minutes longer (systemD timeout).

Good info to add. I don’t think I can help you. There are other people trying to use Prime and Optimus and Bumblebee. May want to do a forvm search.

NVIDIA Prime isn’t the issue; it’s completely separate from the issue in fact. I only mentioned it to give some more background to the issue and to clarify that it has nothing to do with the NVIDIA dGPU, though I find it hard to believe that it is at all related to the graphics stack if even the extensions are failing to function. I mean, OpenWeather is just stuck “loading”, even though I can open the extension’s settings without any issue. The other extensions don’t seem to load at all though. GDM being unresponsive at shutdown, assuming that it is related to the issue at hand, is another sign that the graphics processors aren’t to blame.

I’d try asking in the LinusTechTips forum, but I feel like I’d have even worse luck getting any help/hints, so…

Side note
Optimus and Bumblebee are Godforsaken. Seriously, the only thing that has ever worked for me is NVIDIA Prime.