Ubuntu + steam + network share problems

I currently have a steam library that self updates on a SMB share from my FreeNAS

I have just installed Ubuntu 18.04 lts (I have lightly tried Ubuntu over the years but never got too deep)
And am using nautilus to mount my shares when I’m in Ubuntu. But I need to mount them every time I turn my PC on.

I want to try proton on steam as I am trying to do Linux for a year Challenge that I have now found viable.

But I can’t find my mounted share when trying to add my steam library from my FreeNAS share. I have tried both SMB and Cifs to get to the drive.

  1. how do I automatically mount shares on startup?

  2. how do I add my FreeNAS steam library to my steam on the Ubuntu machine?

Thank you in advance

For auto-mounting the smb share on boot I would recommend this section of this article:


In regards to adding the new mount to your Steam library:

  • Go to the “Steam” menu and select “Settings”
  • Click “Downloads” on the left and press the “Steam Library Folders” button
  • Press the “Add Library Folder” button and select the mount directory

I understand how to add it but I can not find it in directory


I’m at work now but I’ll check if I can repeat the problem at home later.

Thanks mate, appreciate it

my attempt at mounting

The error says that root only has permission. So make sure your have access to the mountpoint.

sudo chown $USER:$USER /media/freenas/shared

Then make sure you have the appropriate permissions set up for the files on the freenas side as well.

Then reboot and your stuff should be there.

1 Like

now my install doesnt boot normally and goes into maintenance mode

Not sure why. You didn’t touch fstab did you?

Even if you get this working, be warned that a lot of steam games just flat out won’t work on a network drive.

I used to use my NAS in this same way, but games like DotA would just refuse to launch.

Been using it for awhile now only had one problem with some starwars games so not too bad

Not since changing first time, how could I fix besides reinstall?

if you take a live a live disk of some distro then you can boot to that, and then chroot into your system and inspect your fstab or try to revert the last thing you did.

If all you did was do the command I listed then that shouldn’t have caused a boot issue. So you’re going to have to be 100% sure you tell everything you did exactly as you did it.

Do you mount your freenas share everytime you boot or do you automount it with fstab? Just wondering.

I was trying to get auto mount working but before that I was manually mounting. I’ll make a live disk’s now

Be sure that you’re not using spaces in fstab. It has to be tabs.

In the link earlier in this post said to replace spaces with \040
So when i copied the original location “\freenas\shared%20storage” (which is how it appears in ubuntu)
so I changed it to “\freenas\shared\040storage”

Ahh. Spaces.

This is why I don’t use spaces.

is that correct? wanna know before i attempt again.

Attempted to fstab but to no avail. new install now

Gotta go to work now will be back at 12:51pm GMT

1 Like

I have to go to work too. ciao. o/