Ubuntu server - Swapped MOBO problems


I’ve just upgraded my ancient hardware to a newer ryzen for my home server, which is running ubuntu server.

I thought I would be able to just swap out the hardware and boot (and largely most things seem to be working) however I am getting a few problems.

One - I run a zpool, half off an old LSI card (Just for the extra ports) and half from the MOBO sata…However I can not import the zpool, it is only seeing the SATA connections, even though I can see the disks in /dev/disk/by-id

Two - I seem to be getting this error when booting
EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?)
EDAC amd64: Error: Error probing instance: 0

Any help would be appreciated

Issue #1: LSI HBAs don’t work with all kinds of hardware, you may need to try another PCIe slot and/or play around with Boot ROM options in BIOS but that doesn’t necessarily fix the issue (ie you may have incompatible hardware). You can’t import pools that aren’t complete for obvious reasons, it’s like trying to read a book with half of its pages missing.

Issue #2: A kernel message shows "EDAC amd64: Error: F0 not found, device 0x1460 (broken BIOS?)" | Support | SUSE
This is pretty much the first thing that pops up if you search for that error message using Google


Thanks for the quick reply

The card seems to be working. I can see all the drives on boot, all OK. They are in /dev/disk/by-id also, so surely they are being detected?

uname -a gives me
Linux server 5.4.0-121-generic #137-Ubuntu SMP Wed Jun 15 13:33:07 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux, so I’m already on a later kernel?

If all devices are detected just import the array(s) manually? It’s impossible to know (given the sparse information) whether all devices are detected or not, only you can determine that. Not being a much of a Linux user these days but all block devices should show up as /dev/sdX so that should be easy to figure out if the kernel sees all or not.

As for the other issue, no idea if it’s a backport done by the distro or mainline. Fire up something like Manjaro (tends to have a relatively recent kernel) off a USB stick and see if you get the same issue?

I’m currently running a dist upgrade 20.04 > 22.04, so maybe that will fix something

The upgrade + a bios update seem to have got rid of issue 2, but still no drives in /dev/

Examine boot log to see if the card is detected

Cant see it on the boot, so not sure what is going on

I can boot into it from BIOS without any problems though

Is that a fresh OS or did you use the old OS from the old machine?

OS from the old machine…Still boots and find the pool straight away.

I also exported the pool

Try another PCIe slot, if that doesn’t work need to look for another controller

Tried another one, also tried setting back to Gen X1…Surely if I can boot into the netbios and see the drives etc, it is working as intended, though?

Can you test it with a new clean install? Or replicate the behaviour in a VM? Would rule out any “legacy”/config or OS-specific reasons

Do you think that could be the cause? Probably could do but would be quite a lot of effort moving over

Then just leave it as a desperate measure if nothing else works. I like to eliminate potential causes to pinpoint the problem.
If you have some USB pen drives (one for ISO and one for the OS), you can quickly test it without overwriting your normal OS. I’d test with some 5.18 kernel distro and clean version of Ubuntu server 22.04

I was never lucky dragging a running OS into a new machine, so I’m a bit skeptical on trusting that OS to get things right.

I’ve written ubuntu to a USB, I’ll give it a whirl, later.

Hopefully like you say I can just get ZFS on the pen drive and see if it works from there

Unless it’s a rather odd HBA you can do the following:

My LSI SAS2008 adapter shows up as:

mps0: <Avago Technologies (LSI) SAS2008> port 0xe000-0xe0ff mem 0xf7dc0000-0xf7dc3fff,0xf7d80000-0xf7dbffff irq 16 at device 0.0 on pci1
mps0: Firmware:, Driver:
mps0: IOCCapabilities: 1285c<ScsiTaskFull,DiagTrace,SnapBuf,EEDP,TransRetry,EventReplay,HostDisc>

To shut it off, type: poweroff -p now

If you can’t find it listed I’d suspect that it doesn’t get initialized at all.

Edit: You should also be able to find it using lspci in Linux

Already tried the lspci in linux and it wasn’t there. I’ll test on ubuntu stick and after, BSD

Then it’s not initialized, try another slot and hope for the best otherwise you most likely need to either switch motherboard or HBA.

Are there any BIOS settings that may be stopping it from initialising?

I’ve tried PCI GEN, fast boot, CSM,